How to get exfat usable?

I had bought a shiny brand new external hdd to act like a source but after its file format conversion to exfat Volumio doesn’t recognise it. I have to exfat it as my osx mbair is my everything :slight_smile:

Can anybody tell me the terminal command I must enter to make it work?


you can try :

sudo apt-get update sudo apt-get install exfat-fuse
But I can’t test it…

Thanks for the tip.

root@volumio:~# sudo apt-get update
Get:1 wheezy Release.gpg [2373 B]
Get:2 wheezy Release [191 kB]
Get:3 wheezy/main Sources [5982 kB]
Get:4 wheezy/non-free Sources [93.5 kB]
Get:5 wheezy/main armhf Packages [5686 kB]
Get:6 wheezy/non-free armhf Packages [55.8 kB]
Get:7 wheezy/main Translation-en [3846 kB]
Get:8 wheezy/non-free Translation-en [66.1 kB]
Fetched 15.9 MB in 38s (417 kB/s)
Reading package lists… Done
W: There is no public key available for the following key IDs:
root@volumio:~# sudo apt-get install exfat-fuse
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following extra packages will be installed:
The following NEW packages will be installed:
exfat-fuse exfat-utils
0 upgraded, 2 newly installed, 0 to remove and 63 not upgraded.
Need to get 95.5 kB of archives.
After this operation, 249 kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Get:1 wheezy/main exfat-fuse armhf 0.9.7-2 [25.7 kB]
Get:2 wheezy/main exfat-utils armhf 0.9.7-2 [69.8 kB]
Fetched 95.5 kB in 0s (110 kB/s)
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = “tr_TR.UTF-8”
are supported and installed on your system.
perl: warning: Falling back to the standard locale (“C”).
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Selecting previously unselected package exfat-fuse.
(Reading database … 25612 files and directories currently installed.)
Unpacking exfat-fuse (from …/exfat-fuse_0.9.7-2_armhf.deb) …
Selecting previously unselected package exfat-utils.
Unpacking exfat-utils (from …/exfat-utils_0.9.7-2_armhf.deb) …
Setting up exfat-fuse (0.9.7-2) …
Setting up exfat-utils (0.9.7-2) …
localepurge: Disk space freed in /usr/share/locale: 0 KiB
localepurge: Disk space freed in /usr/share/man: 0 KiB

Total disk space freed by localepurge: 0 KiB

In the end it didn’t work after all.

after a reboot ?
Or you can try to mount “by hand”
create a mount point

sudo mkdir /mnt/NAS/music (or what you want
sudo mount -t extfat /dev/yourdevice /mnt/NAS/music

and check it


it should return all mount