How-to FusionDsp

I can apply the settings that works. It reverses back when I overwrite the old profile. It changes the name and the nr. of equalizers, but keeps the old values.

As quick solution: can a headphone be deleted manually?

no.
But I really can’t reproduce the issue… So hard to fix it…

too bad…do u have all 5 eq presets in use?

so i have to delete the plugin and reinsrall it ( and reenter 5*10 eq presets uff)

1 Like

No, just 2
which one cause you the issue? All?

I tried with preset 1 and 4, as these were different settings for the sold headphone…didn´t touch 2,3 and 5

So, if I follow you, you can"t save a new preset, right?

can you send log please, just after the problem?

right, i already used all 5 presets.

Full log sent via PM

Here the relevant part copied from the liveblog:

info: CoreCommandRouter::executeOnPlugin: my_volumio , getMyVolumioStatus
info: CoreCommandRouter::executeOnPlugin: my_volumio , getMyVolumioToken
info: CoreCommandRouter::getUIConfigOnPlugin
info: effect true
info:  Dsp mode set is PEQ
info: << convolution filters enabled
info: tools file to play :
info: CALLMETHOD: audio_interface fusiondsp saveparameq [object Object]
info: CoreCommandRouter::executeOnPlugin: fusiondsp , saveparameq
info: Type is Lowshelf2
info: value ok
info: nothing todo
info: CALLMETHOD: audio_interface fusiondsp saveequalizerpreset [object Object]
info: CoreCommandRouter::executeOnPlugin: fusiondsp , saveequalizerpreset
info: State for preset4 = None,false,false,50,0,0,0,None
info: true>---------------------------
info: CoreCommandRouter::getUIConfigOnPlugin
info: CoreCommandRouter::Close All Modals sent
info: effect true
info:  Dsp mode set is PEQ
info: << convolution filters enabled
info: tools file to play :

I saw nothing in log… Investigating…

Let me know if I can help…

Just reinstalled the plugin…will test if it happens again…

OK, after a fresh install of the FusionDSP plugin it works. Did the settings for 4 headphones and used the fifth space for testing…everything as expected. Don´t know what was happening there…

Thank you for your help!

Solved!
The answer is the second part of point A)… it was me…
I wrongly thought that Fusion DSP needed the “software volume” control enabled.
Sadly the switching to “software”, without any Fusion fault, badly degrades the sound quality.
So, everything is fine and many many thanks to @balbuze for the patience kindness and of course great job done in making the Fusion DSP.
:pray:

Glad to read you :hugs:.
But that weird you can notice a such loss in term of quality just because software volume is used. In volumio 3 it processes in 24 b to limit losses.
But anyway, enjoy your music :notes:

1 Like

You can try the Notch Filter.
For my Room i use a Notch Filter with Q 40
40 is the highest you can use.
Maybe that helps

1 Like

Thanks for your responses, I guess switching back and forth between fusiondsp and raw volumio created a bias towards no dsp because of the 2 dB difference in gain. That’s why spl matching is so important in blind testing. Louder will always seem better

Hello. Since v1.0.12, I removed the default -2dB and allow to disable automatic pre amp adjust. You have to ensure to set a correct attenuation to avoid potential clipping.

Thankyou for your reply,
I now understand why my settings are not persistent.
I will now experiment with Fusion Dsp to see if i can obtain the same notch filter that works for me.
If it does …great!
I used the CamillaDSP option because the Gui interface was so easy to use and very user friendly.
I guess i am looking for a “set and forget” setting that is always present when i turn on.
If Camilla dsp can be made to be persistent in the future, it would be a great feature for Volumio.
Thanks again . I will keep on experimenting with this fantastic program!

Bruce

Hello,
In fact, it is already permanent if you process like that :
1- Set FusionDsp in Pure CamillaDsp Gui and open the Gui
image
2 - From CamillaGUi press ‘fetch from Dsp’


3 - Make your changes and press ‘Apply to Dsp’ to test
4 - If ok, save the config by clicking the floppy icon for camilladsp.yml

Now it is permanent. But you have to keep FusionDsp in Pure CamillaDsp Gui! If you choose an other mode, config will be overwritten.
IMHO, unless you need to set more than two channels, it is not so easy to use Camilla Gui for most users
:wink:

3 Likes

Thankyou, i will give :pray: it a try