How-to FusionDsp

This thread is the place where you can ask or explain how you use FusionDsp, how you perform measurements, Eq and your tips.
I will write a tutorial once major issues will be solved :wink:

4 Likes

Online help (available in the plugin)
Here—> Help

1 Like

The best way is to install tools in the plugin and play directly from the plugin. You can add your files in the shared folder


Sorry, but i could not find the answer.
Could be, i dont look enough

In the parametic EQ HZ,DB,Range, what does it mean?
It sounds like, there i could Type an HZ,
as an example 80 HZ. The DB, like 2 DB.
But what does Range really mean?
Could be a Range from 70-90 HZ.

How i have to type in?
Example
80,-2,10 ?
Or is this totally wrong?

Thanks

Hello!
You spotted an error! Range is in fact bandwidth in Octave…
see : GitHub - HEnquist/camilladsp: A flexible cross-platform IIR and FIR engine for crossovers, room correction etc.
I’m going to correct it…
Thanks

Ok,

i tryed to read the page.
I found this for example

parameters:
      type: Peaking
      freq: 100
      bandwidth: 0.7
      gain: -7.3

And this for explanation

  • Peaking
    A parametric peaking filter with selectable gain gain
    at a given frequency freq
    with a bandwidth given either by the Q-value q
    or bandwidth in octaves bandwidth.

So if i understand right:
when i chose in the drop down menue
Hz,db,Range and type 100,-7,0.7
it will be 100hz -7db with an 0,7 octave?

Or is there a good table somewhere, which will explain the options of Bandwich.

Sorry, i only work with q until yet. And i think it will be easylier for me. But i hope i can learn some more over dsp, when it helps to get a better noise.

Perheps you will take this in your how-to, then i will wait :+1:

2 Likes

I have a nasty room mode at around 37 Hz, which makes it rumble even at low volume. I tried to contain it with a single peaking eq (37,-20,30). It somewhat gets the job done, but my impression is that also suppresses dynamic range to some point. Music sounds less energetic and lifeless. Does anyone know why it might happen? I was very enthusiastic about dsp in volumio, but in my case while it solves single problem (room rumble on single requency), it also creates far greater one (lack of dynamics making all music dull). Am I doing something wrong?

Hi Petelskee. Which peaking EQ type do you use: (Hz,dB,Q) or (Hz,dB,bandwidth)?
If you use the (Hz,dB,Q) type, you can try to reduce the attenuation e.g. to -6dB.
Here you can see what you get with (37,-20,30) and (37,-6,30):image
If this doesn´t reduce your room mode enough, you can increase the attenuation in steps of -3dB.

Really, I see no reason for what you feel… But is it just a feeling or can it be measured?
There is no dynamic compression in the plugin.
The only.point is 2dB attenuation to avoid potential clipping due to phase rotation, even with negative value in filter (a point I discussed with CamillaDsp’s author Henrik Enquist.
Everything is processed by CamillaDsp. Can you hear a difference in terms of dynamic when you press " disable effect" ?

@balbuze

Same here…
When I “turn on” or make “active”the plugin (even without any plugin parameters change) the sound quality drops to a unacceptable level (to my ears)…
It becomes shrinked, lower, lifeless and the good “vanilla” Volumio sound disappear in a blink of an eye.
Raw noob (me) analysis:
A) If the sound is modified by the plugin engagement, maybe there is something wrong OR I’m doing something wrong…
B) The “vanilla” Volumio sound is “created” and when the plugin enters in play, the sound returns to its “original state” from where the plugin starts to operate.
It should be instead interesting if the plugin could “operate” STARTING from the sound everybody hear, the “vanilla” sound.
Let me know if there is more to consider or solutions.
Thanks

Are you sure you have No effect (loudness, crossfeed) enabled?
What is your hardware?
I never noticed a loose in terms of quality of sound.
Even with no effect, as soon as the plugin is enabled, the signal goes through CamillaDsp via a Alsa pipe. But it should not alter the sound.
Really, I know it is not easy, but only objective results can help to understand what happens.
As I said, a 2dB attenuation is applied when the plugin is enabled. Not sure it is the reason.
Can you provide a log when enabled and playing please?
Thanks.

Thanks for the prompt reply.

Set up:

Rasp Pi4 (vers. 1.5) 4GB
Orchard PecanPie DAC (HAT)

No other plugins or something else, loaded.
Play:

-Pure Volumio “vanilla” sound.

Installed the Fusion plugin.
Play:

-Pure Volumio “vanilla” sound.

Made active the plugin, but NO parameters change.
Play:

-Degraded Volumio sound (shrinked, lower, lifeless)
The dynamic, the “space”, the “big sound” disappear.

It should be possible to try to “eliminate” this reduction (or this “passage” ) , just to understand if you have found the culprit?

Yes I could. But I need to change the code. I’m not near my device for several hours though…
One way would be to go in Pure CamillaDsp gui.
While playing, press “load from DSP” (or something like that). Then change parameters in pipeline (can’t check now…) and press “apply to DSP”. It could be a quick check.
You can also edit by hand the config file/data/configuration/audio_inteeface/camilladsp yml. Search for the 2dB and set to zero. Save and play
Warning, each time you save something in the plugin, your manual change will be erased.

Thanks balbuze!

The only problem is my IT knowledge… close to zero…
I really have no idea where “to go” to make the changes you kindly suggested nor the way to do it… plus the fear to do something wrong or “really bad”…
I’m really sorry.
If you can do it even later, as you said, no prob for me…
I’m more than grateful.
Thanks in advance !

Ok. I’ll tell you later. Thanks

I just got new headphones and had them measured to get custom EQ settings :-). Also sold an old one for it, so I need to overwrite EQ-settings in FusionDSP.

Problem: does not work right.

  • I change all the equalizer settings and press apply - works
  • Then I go to “Save Current Setting”, choose the one I want to replace - Rename Preset - enter new name - Save

It changes the name, but keeps the EQ settings of the previous headphone. If I add more EQs all the values of the additional EQs are zero.

Would be great if you could take a look there!

In the meantime: how can I delete the old headphone manually, so I can add the new settings?

Greetings,
Stefan

Hmmm, not sure to understand…
You have to add/change EQ and apply before saving preset.
When you save a preset all EQ are stored.
If you create new EQ, you have to save again preset (with or without rename)to be able to call it with last settings. So you don’t need to delete a preset.
Or… ?

The problem is, that it does not overwrite the settings of the old EQ. It only changes the total nr. of EQ…

Little demo. I changed the total nr. of EQ to 1 for demonstration.

Old setting:

New setting (applied):

So far all good. Now I want to overwrite an old setting:

Rename does work, but setting goes back to:

That setting is now saved under the new name:

I am using v1.0.7 (stable)

I can’t reproduce the issue.

When it is reverses back? When you save settings?