How to change retrieved mixer_control string for mpd.conf

I use Volumio 1.55 on a raspberry pi2 with a Hifiberry DAC+

The bug is related to selecting “Volume hardware control” in the WebGui
which is not working properly.

After installation and configuration of volumio I ran twice into the problem that the mixer_control in the audio output section
changed for no apparent reason from the initial, working “PCM” to the incorrect “Playback Digital”.

Volume hardware control of course does not work anymore after that!

In /etc/mpd.conf:

audio_output {

                 type           "alsa"
                 name           "Output"
                 device         "hw:0,0"
                 mixer_control  "Playback Digital"
                 mixer_device   "hw:0"
                 mixer_index    "0"
                 dop    "no"


The output of the amixer version does not have such a “simple mixer control”!

root@volumio:/home/pi# amixer sget "Playback Digital" amixer: Unable to find simple control 'Playback Digital',0

I can of course set the mixer_control in mpd.conf to the corresponding value from amixer output and the slider works again,
but any change in the webgui resulting in a restart of mpd brings back the faulty string.

I would like to see a more flexible setting of the Volume Hardware Control for example by using the actual amixer output.

In the meantime I would like to know where I have to change the “Playback Digital” string (file database?) to have the webgui work correctly?

kind regards

Is this problem still not solved? i have a Raspberry 2 with Hifiberry + board and cannot set the volume to hardware control! The chipset is ready for it, please make this possible, i love the volumio solution but this one problem needs to be solved.