How to change CPU governor to ondemand for PC version on a netbook?

I am running the latest PC version on an old netbook with an Atom N550 CPU. Sound is being output from the headphone jack so no DAC or USB is being utilized. The one issue I am having is that the CPU is set to performance which is causing the fan to constantly run at an audible level. While listening to music this isn’t a big deal since it’s quiet enough that it’s not audible over the music. However, the device spends most of it’s time idle and the constant fan noise is very noticeable and unpleasant when not playing music.

I am still a linux newbie, but was hoping someone could provide guidance on how to change Volumio to run the CPU with the governor as ondemand and how to make that setting stick upon reboot.

Personally I prefer the “schedutil” setting to ondemand, i.e. for cpu 0:

sudo sh -c 'echo schedutil >/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor'

To make it stick you could add the echo command to /etc/rc.local, but make sure to insert a delay of some x seconds with a sleep x command before it, otherwise Volumio might reset it to performance as part of its initialization.

Volumio does not reset it during initialisation, at least not for x86, so you’re safe putting it in rc.local.

Thanks for the replies. Prior to reading these I had found a guide for another operating system that suggested:

sudo nano /etc/default/cpufrequtils

And then edit the line to read:
GOVERNOR=“ondemand”

Save and exit.

For changes take effect, run:
sudo systemctl restart cpufrequtils

I did that and the changes persist after reboots. Does this work or will future Volumio updates overwrite this? Just wasn’t sure if the suggestion here would be better.

Thanks