How can I add a pendrive with music on Volumio 3?

Hi everybody,

I just got my PI4 today and flashed Volumio 3.233 right after, so I am fairly new to this world.

Also I have not used any Linux distro in the past 15 years

I am having some serious problems trying to add my NAS to volumio, but I´ll open another thread for this.

IN this topic I would like to ask you guys to help me add a pendrive to my PI4 and to volumio, so I can read some DSD files directly.

I could not find it from any of the menus and I also tried MKDIR and MOUNT, but even as root I get the error filesystem is read only and I cannot proceed.

Could you guys give some hints on how to do it right ?


Well, no gentle souls to help, but what I found was that V3.233 was full of bugs and this behaviour was a part of that.

After some time trying to make things work, I decided to download the latest version of volumio2 and it all stated to work just fine.

But today I just decided to tey again and found out how to upgrade V3.233 to the latest bet version, V3.248 as of today, least this issue (plus not beeing able to mount my D-Link NAS) was solved.

So I hope this may help other newbies like me to be able to use Volumio OS V3.

Normally a usb drive should show up by itself (mounted automatically by Volumio), unless the drawn current is too high. or an exotic file system has been used on the USB thingy.
Only experienced the same behavior, when connecting a SSD. Ended up using a USB thumb from Sandisk.

Thanks, but it was just the BUGS in V3.233.

V3.248 (beta) solved all the issues.