Hotspot fallback fails to start

Hi all
We are losing our broadband due to street work.
Not a problem, I thought.
I usd my phone hotspot and managed to get Volumio connected to this, I checked ‘hotspot fallback’ was enabled, it was.
Now when I turn off my hotspot Volumio does not see it.
It’s a fresh install tonight ( done to see if it would cure problems. )
I’m at a loss, surely using Volumio completely headless, and using the burst of internet, would sort this?

What I mean is hat when I turn off my iPhone connection to the Volumio initial hotspot, the WiFi then being gone, the hotspot does not start, meaning. Can’t connect

Or never somebody can give complete guide to zero internet playback, using only phon hotspot to load album covers etc.

So, are you saying that your Volumio device does not start it’s “hot spot” when it can’t find a wifi connection? Sorry, but your posts weren’t too clear.

Sorry , yes that’s right, on a fresh instal I get the hotspot, but after setting up a temp WiFi (to populate album covers etc)on disconnecting the WiFi I don’t see the hotspot from Volumio

Just tried here, and with hotspot fallback enabled, the hotspot starts when there is no wifi. Can you attach your device to a monitor and keyboard? If so at the command prompt, type ‘sudo ifconfig’ and ‘sudo iwconfig’ and post the results here.

What device are you using , and what version of Volumio?

P.S. It would be a good idea for you to edit the title of your original post to something like “Hotspot fails to start when no wifi.” People are much more likely to read and reply if they know what the problem is.

Haven’t managed to connect keyboard and monitor yet, but I reinstalled Volumio again this morning, no plugins installed and still doesn’t work.
I’m beginning to wonder if it’s because the only WiFi I have at the moment is my iphones wireless hotspot.
Maybe Volumio sees it not as a wireless signal as such but as another hotspot so when I turn it off it doesn’t fall back.

Also with iPhone hotspot off, a reboot of Volumio does create its initial hotspot just fine, but on activating iPhone hotspot Volumio fails to connect to it unless I go into network settings and manually choose it.

I’m getting quite frustrated to say the least.

I’ve reread this thread a bit more carefully.

(1) boot RPi without iPhone hotspot … Volumio hotspot will appear, and you can add your iPhone’s hotspot details on the network page, and save.

(2) actvate iPhone hotspot & your RPi should connect to it allowing it to get album covers etc. At this point your RPi will have been given a different IP address from in (1), and you will not be able to connect to it, except on another device connected to the iPhone hotspot.

(3) Deactivate your iPhone hotspot & RPi should now boot up again with it’s hotspot to which you can connect your iPhone and view Volumio.

So, you need to leave it for a sufficient amount of time (no idea how long) at stage (2) to get your cover art, or borrow another phone/tablet/laptop etc. to connect to the iPhone hotspot and Volumio (you can then see when you have got all the cover art).

Or you could just put up with no cover art for the short term :slight_smile:

Thank you for your continued help with this bud, I am currently doing exactly as you have listed, have been nearly all morning.
The problem is step 3, when I turn off iPhone hotspot Volumio does not activate its own hotspot, even with fallback switched on.

I’ve reinstalled, tried a factory reset but all to no avail, it just will not fallback to its own hotspot unless I manually reboot pi.

I don’t know the details but perhaps what you’re expecting is not actually programmed ie. hotspot only occurs on boot if no wifi. Why is that a problem anyway? Are you intending on using the iPhone hotspot a lot, or just to download the coverart as you originally said? That said, I’m going to test it now on my android …

Can you open an issue on Github for this? I can take a look next week

Ok maybe I was expecting something it cannot do, I was under the impression that if WiFi failed or was disconnected that Volumio would automatically fire up its own hotspot without any intervention?
If I have to manually reboot Volumio then it isn’t able to do what I expected ‘hotspot fallback’ to do.

This seems to make the fallback option redundant in my eyes, if WiFi fails then I could just reboot anyway to get the built in hotspot.

And Michelangelo, I don’t know how to raise this issue oh github but also if I have to manually reboot as chsims1 says then I feel it would be pointless.

I really thought, having read info on hotspot fallback that it would be an automated process.

Hotspot fallback should do exactly what you think: in case wireless connection is lost, it should restart hotspot .

Bear in mind that it will wait some time before doing it. Can you try to wait, let’s say 2 minutes? Let me know

Ah ok it is meant to do as I expected!
I have already tested leaving it lengthy periods of time, including overnight last night, I’m at the limits of my technical knowledge now, fresh installs, no plugins that might interfere.

Pi can’t be faulty as on a reboot the hotspot appears.
Just won’t automatically appear without reboot.

Ps have managed to raise a ticket on github too.
Thanks for looking into this.

Can I also add that when I turn back on iPhone hotspot that Volumio does not connect to it without manual intervention also.

Done some testing …

the Volumio hot-spot is only started from a boot and not finding wifi … not for when the wifi/mobile hotspot fails. If the wifi/mobile hotspot comes back on, the Volumio hotspot is dropped and connection to wifi made.

Thanks for testing chsims1, then it seems Volumio team have some work to do as that’s not what is expected as per Michelangelo.

Thanks for taking the time to test buddy, much appreciated, thought I was going mad.

Latest update still has no fix in place, but dispondent now. A simple headless operation requires so much interaction now it’s become a chore.

I confirm, fallback Hotspot function does not work as described in Volumio (distri downloaded today). Disabling configured in Volumio wifi network does not cause Volumio Hotspot to start even after 20 minutes…

It is somehow umbelivable that some options are added without testing…

I’d pretty much given up on this being resolved, does anybody know if any other similar software does have a working hotspot fallback included?

Sorry to say: +1 from me.
But not only that.

I configured a fresh install of Volumio for use with a fixed IP on my wireless network.
I let the hotspot setting to “ON” and “AUTOMATIC”.

If my wireless network is up the PI connects to it, after reboot, and everything is fine.

Then i switch off my wireless router and, of course, the PI stops working (there is no wired lan attached).

To my surprise the built-in hotspot does not start even after some 5 minutes.

So, i turn on my wireless network again and after another 5 minutes the PI still does not (re-) connect to the network.
It cannot be seen inside the routers ip tables, no ssh, nothing.

So this is not only a problem that the hotspot fails to start, it is also a problem of wlan reconnect.
I know that this function worked flawlessly in an older version of Volumio so i am optimistic…

Anyway: The PI is up and running when i connect wired lan and i can reboot the whole thing and everything is
fine gain.

By the way: I came on track of this because i tried to run Volumio 24/7. It is planned to use the attached storage
via Samba to store some data on.
But after the second night, the PI gave up.
Seemingly the forced disconnect of my router overnight sometimes drives the wlan of the PI into timeout and after wlan is up
again … nothing. See above.

We will look into this in the next week. This is due to a regression on something we’ve done on the dhcp client, sorry guys about that