Horrible - Raspberry Pi + Wavelength Audio Proton

Maybe (touching… ) we have the solution:

1- Connect to SSH (user root, password volumio)
2- edit /etc/modprobe.d/alsa-base.conf with
nano /etc/modprobe.d/alsa-base.conf

and add this line in the end of the file

options snd-usb-audio nrpacks=1

3- save with ctrl+x
4- reboot
5- report here how this goes. If it works, I’ll drink a long-island to you guys tonight! :smiley:

If you was a girl… I’m gonna merry you …hahahahahaha.

Cheers with my beer,


I’m flashing SD Card with Volumio right now…
I couldn’t handle 4th day without music so I installed RaspyFi again :stuck_out_tongue:

fingers crossed! :slight_smile:


It doesn’t work :frowning:!

cat /proc/asound/card0/pcm0p/sub0/hw_params access: RW_INTERLEAVED format: S24_3LE subformat: STD channels: 2 rate: 44100 (44100/1) period_size: 5513 buffer_size: 22050

[code]dmesg | tail
Contact linux-ext4@vger.kernel.org if you think we should keep it.

EXT4-fs (mmcblk0p3): re-mounted. Opts: nouser_xattr,errors=remount-ro
NET: Registered protocol family 10
IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0xCDE1
Installing knfsd (copyright © 1996 okir@monad.swb.de).
5:1:1: cannot get freq at ep 0x1
5:1:1: cannot get freq at ep 0x1[/code]

This fix worked for me!
clear playback on mp3, 44.1/24, and 96/24 FLAC content using the default settings. no resampling.

verified bit perfect playback with: cat /proc/asound/card0/pcm0p/sub0/hw_params

lucky you :slight_smile:

I’m working on this:


GREAT!!! :smiley:

Sorry for late response, but yes - this line fixed the crackling on my R-Pi+audiophilleo2 Volumio instance…

Grazie. I owe you one of those long-islands. :wink:

hey guys i have had this same problem and there was a fix for the original raspfi for usb dac output that should fix our problems. here is the link i have found raspyfi.com/raspberry-pi-usb-audio-fix/
i am installing it now to see if it fixes the problem but i have 3 usb dacs that have the same distortion so that tells me there is some packet loss.
list of dacs
1.objective dac
2.destroyer dac
3.ud110v2 by stoner acoustics

ok here is update on the fix
i ran from the pi
sudo apt-get update (let it update)
sudo apt-get install git-core
sudo apt-get instal binutils
sudo BRANCH=fiq_split rpi-update
then walk away for a few heat you up a cup of coffee or get a beer it will take about 10 min or so then restart your pi i didnt edit the mpd.conf
i just left it alone and it has no more stuttering!

That’s another clue, means that the current kernel has some problems… However doing like that breaks i2s support…

This was implemented in raspfi and it worked fine but I will look into it a little more

is there any reason we are using this kernel for volumio when the current one for the raspberry pi seems to work on more devices than the kernel that is in volumio?

1.1 beta
works good, nearly as good as RaspyFi.
Still some zaps accrued but I can live with with it :slight_smile:

Thank you!