Horrible Noise on Startup with USB Audio Device


I am trying to setup a Squeezebox System using a Raspberry Pi 3 B. I recently bought a SMSL AD18 Amplifier with integrated USB-Interface. The USB-Interface is recognized by Volumio and the sound is playing through my amplifier.

But I have a big problem. When restarting the Raspberry, I get a horrible distorted noise out of my amplifier while the system is booting. I’m glad, I turned the volume down before the first trial because otherwise I might have destroyed my speakers.

I have tried different platforms, all show a similar effect:
When starting Volumio the noise starts a few seconds after I power on the Raspberry. It lasts about 7 seconds and stops right at the moment, when the Volumio Screen appears on the HDMI-out.
With PiCrePlayer the noise lasts about 5 seconds, with mx2play it’s only about 1 second.

Do you have any suggestions? Many thanks in advance.

I try to deliver some more informations, so maybe someone can help to solve the problem.
I guess the problem is happening when Linux is discovering the specifications of the audio interface. Directly after switching on the Raspberry the interface shows “no Signal”. The noise occurs while the interface is switching between 44.1, 48 and 96kHz Sample Rate. It stops when the display shows 96kHz.

When using the lsusb -D command through ssh i get the following informations:

I guess the noise is caused by the raspberry trying to establish a 88.200 Hz Sample Rate. Is there a way to prevent this procedure?

Edit: I connected the Audio Device to my macbook which causes the same noise for about half a second every time I plug-in the usb cable. I also could establish a sample rate of 88.200, so this is obviously not the problem. I now guess there’s a problem with the audio-interface. Maybe it’s unmuting too fast after receiving a new connection? The AD-18 shows firmware version 3.1 on startup, but I couldn’t find an update file on the manufacturers site.

Hi Domonid,

I got the same issue on SMSL AD18, which was bought couple of days ago. I’m not the tech guy, but I tried my volumio on other platform I owned, like Creative Sound Blaster ROAR2 and a DIY xmos usb dac, all works pretty quiet. So I guess this is caused by SMSL AD18, the default volume for USB input is set to 7, which is pretty high, when Volumio(RPI3) does startup, the USB ports will do charge to other devices which will generate current, and the current make noise to your speaker… that’s my assumption. :unamused:

Hi telar,

I wrote a second post about my conclusions. But since I edited it yesterday it is hidden and waiting to be approved by an admistrator.

I also wrote to the SMSL support. This is what they were answering:

I asked about future firmware updates and if the SMSL Q5 pro will show the same behaviour. I can let you know if I get a new answer.