HiFIBerry Digi+ Pro and Allo DigiOne Volumio special Version

This is an experimental version of Volumio with support for:

  • HiFIBerry Digi+ Pro
  • Allo DigiOne

updates.volumio.org/pi/volumione … pi.img.zip

Some things to note:

  • The OTA update will not work with this. It is completely detached from the ordinary Volumio version, so don’t expect any update, and use the OTA at your own risk
  • The HiFIBerry Digi+ Pro will be automatically enabled if connected, no need to enable I2S DACs. Just go to Playback Options and select HiFIBerry Digi+ Pro from the output device menu.
    For best quality don’t use Software Mixer Control (although it works)
  • To enable Allo DigiOne go to Playback Options and enable i2s DACs, then select Allo DigiOne, click save and reboot
  • This build uses an experimental new kernel, so please if you notice weird behaviour report to us in this thread. It will be very important for us to receive feedbacks


Quick question; given that the HFB Digi+ Pro and the DAC+ Pro look as if they share design philosophies, will support be extended to the DA+ Pro?

Yes, it should be already be supported anyway

I have tried him now (HiFiBerry Digi + Pro) and, in my opinion, sounds better than usb.

nice work :smiley:

What USB DAC do you have?

denon DA-300usb.

With improved linear power on the denon DA-300usb and linear power directly on the raspberry.

The sound is now much better from the speakers, a much more beautiful stereo image, the instuments are much better heard, much better detail.

Coax or optical SPDIF?

Verzonden vanaf mijn iPhone met Tapatalk


Is Shairport Sync also included in this release or is it still the ‘standard’ Shairport package?

Hi @Michelangelo,

Yes, it’s supported but only by the same driver as the DAC+ as far as I know; I don’t think there’s any special use of the separate clocks available in the same way as this Digi+ Pro is supported…

Chris M

Thanks a lot it works perfectly now !!! I’m happy getting back with Volumio, Volumio missed me since I’ve bought Digi+ Pro two months ago. Thanks for your good work, greatly appreciated !


Is Shairport Sync also included in this release or is it still the ‘standard’ Shairport package?

Shairport sync is included by default both in standard Volumio and this version as well

ok, thx I will download and test it in a few days when I have some spare time :sunglasses:

thank you very much for the work done, having to flash the card and to put the settings parameters to volumio is so easy that it is little work for the result obtained.

Update I also tested the dac Audio-GD NFB-1 (2015) and it sounds even better :smiley: both usb and hifiberry digi + pro where the digi + pro sounds better than usb is my experience.

First try it was ok, but after adjusting some settings I couldn’t connect to the streamer anymore (using Airplay/Shairport).

I had to reinstall the image on the SD card to get connected again.

I don’t know whether Shairport OR Shairport Sync was in use? Shairport is not as stable as Shairport sync (the same experience with Runeaudio beta which uses Shairport instead of Shairport Sync. Moodeaudio is not a problem which uses Shairport Sync only).

In addition I found it regrettable I couldn’t configure kernel settings for better sound performance.

Keep on the good work!

Problem with Plugins
Installed the new version 2.203 and it works fine with the HiFiBerry Digi+ PRO card. Excellent ! Back to Volumio from Rune.
I have a test set-up with 3 buttons and LCD, using the Plugins:

  1. GPIO Buttons Controller
  2. Raspdac V3 Plugin
    The set-up worked fine with Rasp2 running Volumio2, standard version. Both buttons and LCD worked fine, no problem.
    The final goal is to built a Media player with linear power supply, (3.3 and 5.0 V), LCD and some buttons on the front panel to make it look nice. The DAC is AMB Gamma3.

Installed both plugins.
switch on (1), works fine; pause, forward, back, no problem.
switch on (2), the titel flash on to the LCD display, and after say 3 seconds the Volumio freeze.
The LCD is using the following GPIO: rs: 7, e: 8, data: [25, 24, 23, 27] (Default settings)
The GPIO buttons, using: GPIO: 26, 15 , 14

Any idea why this happens, have now made three tests, same result each time.

And if I would like to logon on this image using SSH, which account name and password should I use then?
Thanks in advance.

FOA, we use shairport-sync. Could you share more informations about the custom code you’re using?