Hifiberry digi+ not working after update to version 2.285

I have an rpi2 and after the update to version 2.285 my Hifiberry digi+ stopped working, no sound neither from spdif nor toslink. I rebooted several time, dismounted the board and assembled it again but nothing happened. I thought it was broken but I tried to select IQaudIO Pi-Digi+ and it worked(!) but I don’t think it’s the right driver. I read in the changelog “Update hifiberry DAC naming” and in this version Hifiberry digi+ is not listed (but I don’t remember if it was listed in the previous version), only the digi and the digi pro+ are present. Maybe something went wrong during the renaming. Could you please fix this?
Thank you very much for your great work.

You can select hifiberry digi pro and it will just work, let me know (ps reboot after you save settings)

Hi Michelangelo,
Thanks for your reply.
I tried every Hifiberry device listed in the menu but no one worked.
Just updated to version 2.296, tried with digi and digi pro+ but it’s the same.
Switched back to IQaudIO Digi+ and it worked.
I’m using the digi+ with Volumio from June 2016 without problems so I think it’s related to the “updated Hifiberry DAC naming” in version 2.285.
The digi+ is different from the digi pro+ as the last has two different oscillators and is supported in Volumio only since few months after kernel update (I found this info in other treads in the forum).
Best regards

running digi+pro & rpi3 on volumio 2.295. So it must be a local issue. About to update to 2.298. Lets see how this goes

But my setup is different: digi+ (not digi+ pro) and rpi2.
Maybe tonight I will reflash Volumio.
Hope this fix it.


I apologize for my first post.
After a fresh install of Volumio the digi+ work again.
Anyway the right I2S device to select is the Digi because if I select the Digi+ Pro the music is played back at double speed :slight_smile: :astonished:

Really? I think you should notify to hifiberry, so they know that their modules in latest kernel has this side effect