HifiBerry DAC+ Pro

Sorry a noob here…so please forgive my dumb questions.

I just received my Raspberry Pi2 and the HifiBerry DAC+ Pro this morning in the mail. Has anyone else picked this combo up? This is one that has the internal clock and gold RCA connectors.

I have updated the Linux kernel to 4.1.11 which includes the latest drivers for the HifiBerry DAC+ Pro. The system recognizes that I have HIfiBerry DAC+ Pro installed (as opposed to just HifiBerry DAC+) when I type the command “aplay -l” under SSH.

I currently have Volumio v 1.55 running. But under the drop down menu it only shows HifiBerry + as the only appropriate option for i2S DACs. I was expecting to now show a DAC+ Pro option. Will this be updated sometime soon? Or am I doing something wrong?

The driver is the same for both DACs as far as I know. The difference is only in the hardware components.

Just use the one option in Volumio and you should be good to go.

Sent from my iPhone using Tapatalk

Awesome. Yeah I plugged it all in last night and it seems to be working fine.

I was just wanting to make sure I was having DAC use its own internal clock generator as opposed to just using the clock from the Pi 2.

Sorry, it seems that while the Hifiberry pro is working with the hifiberry dac + Driver, the dual clocks are not in use. They will be active with a new driver, which is already available in the latest linux kernel.
This thread on the hifiberry page https://www.hifiberry.com/forums/topic/dac-pro-2/ quite clarifies the situation.

Will Volumio 2 be able to use onboard clocks of the Dac Pro?
Building an image with a different kernel is way beyond my talents.

Can we use it with v2’s latest build?

Yes I have been running the latest Volumio2 for quite a while with DAC+ Pro.

Sorry for late reply… Yes Volumio has full support for the DAC+ PRO and its onboard clocks!

Hello, I have a HifiBerry DAC+ Pro on Volumio 2.0.41 (current version). :smiley:
In previous version of Volumio it was possible to disable volume control which was resulting in a clearly better sound. :astonished:
When I do that in volumio now, no sounds comes out of the card anymore. :frowning:

Can you tell me how to fix this (I can access configuration files manually to fix it). :question:

Thank you in advance. :exclamation:

Yes I will investigate on thisissue and let you know!

Thank you!

Anything more on this one, @michelangelo?


Sorry if I’m hijacking the thread. I have tried to find an answer for my question, but without any luck.

I just got the HiFiBerry DAC+ Pro for my Raspberry Pi 2 Model B. At first I used the installer from HiFiBerry and installed their image for Volumio. This seems to work fine, but to my dissapointent it’s comes with version 1.55 of Volumio.

I’ve tried the official Volumio image (Version 2.041) for Raspberry Pi, with two different SD-cards, but I end up with a black screen and no booting.

Any clues? Is this setup not compatible with Volumio 2?

Thanks in advice!

Ah well, this one doesn’t seem to be getting anywhere quickly, so …

Sounds like your SD cards aren’t correctly written. The setup you have is the same as mine and mine works just fine. Since your version of 1.55 worked, the hardware isn’t in doubt, but the act of writing 2.x is in doubt. Try using Win32DiskImager if you’re using Windows as a host, or PiWriter if you have a Mac.

I have a BRAND NEW Raspberry Pi 3 and the HifiBerry DAC+ PRO (HW2.2)

I have set the correct settings in playback, but no matter what I do I get the “Failed to Open Audio Output” error and hear no audio.

I have NO OPTION For DAC + Pro, rather only the +




Use the + option, it will work

Tried it…“Failed to something audio output”

i SSh in and it doesnt show the device with the aplay command…


Failed to open audio output.Screenshot 2017-02-15 20.00.08.jpg

Really starting to think this DAC is bad or something…


I have tried the following

  1. Rechecked the installation into the HifiBerry Steel case to be sure the contacts were solidly made.

  2. Flashed the SD with the HifiBerry modified Debian package, booted, and checked with aplay…the DAC+ Pro does not show up. Upon editing config.txt and disabling onboard sound…aplay states “no soundcards found”

  3. Flashed with Volumio, Moode, and RuneAudio. None of these list the DAC+Pro as an option except Volumio. The others don’t give me an output option other than HDMI or analog. Upon disabling onboard sound, no options were listed.

  4. Flashed the DAC Pro by using the flash image and the white button. The “now writing” occurs without pressing the button. No tone is played when it “finishes” nor does the LED on the board light up.

The DAC Pro LED NEVER comes on…Volumio, RuneAudio, Moode, Modified Debian, Raspbian regular…NOTHING.

Defective board guys?