HifiBerry DAC no sound

I started my new Raspberry Pi build before - RPi2+HifiBerry DAC+Volumio (latest version), but I’m having problems enabling the DAC.

If I enable i2s, and select “HifiBerry DAC”, I get no sound at all.
If I disable i2s, and set to “Audio Jack” I get sound form the 3.5mm socket.
If I enable i2s, and select “Allo BOSS”, I get sound through the DAC RCA connectors. But, the sound seems very weighted towards the centre - almost as though it’s Mono.

I’ve tried disabling i2s, rebooting, re-enabling i2s and rebooting but still didn’t seem to give any output set to “HifiBerry DAC”.

Any suggestions? How do I tell if my board is “HifiBerry DAC” or “HifiBerry DAC+”? I bought it a while ago.

For HiFiBerry, there’s either a single crystal device or the dual crystal, the Pro. The board itself will have a name on it, but it’s very likely that you have the DAC+. Anything else is likely to be Volumio not getting its naming correct.

If you’re getting any sound out of it, with any settings, then the board is working; for me, whenever I’ve had weird shit happen with a Pi, I’ve always found that throwing the microSD card away and starting again with a new one fixed it…

Ok, this is really annoying now.

I don’t know how, but it did finally start working, and has been for a while… until I changed something for testing. Now, I cannot get it to go back onto I2S.

So, I set I2S DAC “On”, select DAC Model as “HifiBerry DAC Plus” (which I know it is now), press “Save”, and as soon as I reboot, it’s back to I2S disabled.

I’ve tried setting it so many different ways - starting from HDMI/Audio Jack, also tried setting to Allo Boss which gave me audio before somehow, but it just keeps defaulting back to I2S “Off”. Help please!

Is there a way I can configure this through SSH, rather than the buggy UI?

Every time the RPis have misbehaved or begun to behave inconsistently, I’ve bent my brains around testing the damn things until… I try a new SD card. That has always worked, so try a different SD card with Volumio and the logical card settings, then see what happens,

Chris M

Hi,

I have the same problem with my dac plus pro (that version I can not choose) but after restart, i2s is off. It’s happening after latest Volumio version.

SD card new and reimaged.

Besides is there a setting for the pro?

Regards,
Ad.

Verstuurd vanaf mijn SM-G960F met Tapatalk

Hello,
same issue here with Raspi PI2B and Hifiberry DAC+. I choose the DAC+, Alsa Error, I switch I2S off, restart, then choose Hifiberry DAC, restart, change to DAC+ (without restart) and it works. After a reboot in some cases I2S is again off, or the setup of the DAC is back to Hifiberry DAC.
So I took the setting wit Hifiberry DAC and the System runs stable, also after rebooting. But now I would be interested if there are any differences between the settings of DAC vor DAC+. Are there any effects in sound quality or compatibility?
Any idea of other users or Volumio?
Regards leo

Check the PSU voltage at the DAC. They can be fussy and like 5.2VDC.

Thank you for your reply. I tried another PSU (original Raspberry) output 5,1/2,5A and it is the same. Maybe I find a PSU with 5.2. Do you have a recommendation?

Hi Bigguy !

Does your Tinker board setup sound better than your RPI?

Regards.

There’s not a lot of difference I can hear between the OSA Dacberry One and the HifiBerry DAC; the OSA has a little more bass and sounds a little more focused. It depends on the track being played.

Re PSUs; I found the official Pi PSU (5V1) works well.
Also the NorthPada Raspberry Pi 3 Model B 3A Power Supply.

I’m using the MeanWell RPS-30-05 30W PSU (which has an adjustable 4.7 - 5.5VDC output) in my Volumio players and find them totally reliable at 5.25VDC.

https://volumio.org/forum/volumio-build-t9833.html

Hi

I bought Raspberry Pi 3 Model B+ with HIFIberry Digi+ Pro .

I’m using VOLUMIO

I want use S/PDIF output to connect my DAC

After many test it doesn’t work, No Audio from S/PDIF output or RCA Connector ( Only USB from rpi…)

but…

SOLVED

It is necessary only to follow the steps :
1 Reinstall SW on SD
2 plug in the HIFIBERRY
2 Start new configuration of Volumio from scratch .

Hi
I have a DacBerry one+ board and have the same issues as you describe, with no sound from either RCA or S/PDIF on the board. I manage to get sound on headphones from the DacBerry board, so it is communication with my RP 3+, and Volumio. I have tried different power-supplies, but no change in my issue.

What versions of Volumio have you tried with?
Did you change version?
What is the version that is working?

Best regards
R, Norway

There is a known problem with debian not detecting the DAC correctly.
I used to use a static config in /boot/config.txt


initramfs volumio.initrd
gpu_mem=32
max_usb_current=1

Own parameters

dtparam=audio=off
dtparam=i2s=on
dtoverlay=hifiberry-dacplus

audio_pwm_mode=2
disable_splash=1
hdmi_force_hotplug=1

include userconfig.txt