HifiBerry DAC 2 HD

Hi there!
I just got the HifiBerry DAC 2 HD and tried it with Volumio but unfortunately it doesn’t seem to have the correct driver just yet. I tried all common DAC drivers but I get an ALSA-not found error.

Is there a fast way to make this DAC compatible with the current Volumio version? I would be glad to provide any details you would need! Im from germany so please excuse my english and it’s already 11pm here so maybe I can only reply tomorrow since I need to work early in the morning.

Thank you all in advance!


See here:

Hi pwstereo and thanks for your reply. Unfortunately I got it to work!

I updated to the Beta branch of Volumio (Test Mode) and added this line to the dacs.json:

{“id”:“hifiberry-dac2hd”,“name”:“HiFiBerry DAC2 HD”,“overlay”:“hifiberry-dacplushd”,“alsanum”:“2”,“mixer”:“Digital”,“modules”:"",“script”:"",“eeprom_name”:“DAC 2 HD”,“i2c_adress”:“4d”,“needsreboot”:“no”},

Although I set it to “needsreboot” no I had to reboot to get it to work. That means add it to the dacs.json, reboot, pick “HiFiBerry DAC2 HD” of the list and reboot again. After that it worked right away.

The only thing that doesn’t work is the volume control. But its not too bad it’s at a quite normal level.

The System Version is 2.798

I can control the volume through commandline using alsamixer. I need to select the dac with F6. It’s set to HDMI by default. It’s not possible to change it in the user interface in this version of Volumio. Need to figure out how to change that in command line.

Curious if you’ve used any of the other Hifiberry’s and how is the dac 2 hd in comparison? Is it a worthwhile upgrade?

Unfortunately no, I only own the DAC2HD but I use it with a DENON 7200WA which is not a low end AV-receiver and it’s notebly better than the integrated circuit. Sorry for my english…

The DENON 7200WA uses the AK4490 32-bit whatever that means.

The problem is that the Radio via Internet function has been disabled recentely so that’s why I added the raspberry.

We included the driver for Hifiberry DAC2 HD in the latest version (2.799 ) of Volumio :wink:

Yeah I just realised that after I killed my rasp3b after shorting 3.3v with 5.0v and had to reinstall on a Rasp4. Missed the “thank you Tylli for trying out that expensive piece of sh…” :smile:

It’s by far better than the integrated one in AVR7200WA but thats the only comparison I have.