HiFiBerry AMP2 the right settings

Volumio Information

Volumio Version: 2.834
Hardware: Raspberry Pi 3
DAC: HiFi Berry AMP2
I’m using the Volumio more than year with the HiFiBerry AMP2.
It is bit strange that I can’t change the volume for quite mode playing.
Actually if change the volume for 1, it is still quite loud.
In the 2019 there was HiFiBerry AMP2 selection and it was run fine with fine sound selection.
I wondering from someone who have similar issue or what is the right setting solution for the HiFiBerry AMP2?
If I set the I2C for HiFiBerry AMP - there is no sound, so I set it for the HiFiBerry DAC Plus.
DSD Playback mode: DSD Direct
Mixer Type: Software
With this configuration there is sound but, low volume settings (for example: 1) is still loud.

Why do you use a software mixer while your Dac supports an hardware mixer called ‘digital’?

1 Like

I was try, but there was no any sound…
Now I was change it, restart the the Rp - and the sound was start on full volume.
But the end is: now fine it could be set fine.

Thank’s for you support and time!

I just installed hifiberry AMP2 on a Pi, have another pi with the original hifiberry amp working. I noticed no selection for amp2 but there is one regular hifiberry amp selection. Its showing an ALSA error when trying to play files and no sound.

@Vas_Dau that is because hifiberry explicitly states that the AMP2 is to be used via the DAC-plus overlay, not the amp overlay

@iven have you tried to change the maximum volume in alsamixer within the shell? I have used this some time ago but do not remember if it was in volumio or simply raspian. In raspian, it works flawlessly. Anyhow, balbuze is correct to suggest to change the mixer in case you had it wrong. In case you want to set a system wide max volume try to set the alsamixer to 50%, that is what I did with amp2 and merus12070 as they are way too loud

Hi ! Do you confirm it works (volume control too) by using HifiBerry Dac + ?

Thanks, figured it out. i had an old hifi amp and new amp2 and thought the same config will work on both

Hi,
I was not try it in the shell - because there is option on the Volumio UI - it is true - it was nice working last year - but now you can set it - but it is not working - I mean the limitation…

This Dac has been added, so should be available in next release.