Help with Volumio on Raspberry Pi Zero + ES9023 DAC


I’m trying to setup Raspberry with Volumio. Here’s my progress.


  • Raspberry Pi Zero
  • Audiophonics DAC Sabre ES9023 I2S DAC
  • Micro USB hub with RJ45 (Terminus Technology Inc, 4-Port HUB + Kontron DM9601 Fast Ethernet Adapter)
  • USB Wifi dongle Realtek RTL8188CUS 802.11n WLAN Adapter

Here’s the wiring :

[code]I2S :
Orange: MCLK /
Yellow: GND -> pin 39
White: DATA -> pin 40
Red: LRCK -> pin 35
Black: BCK -> pin 12

Black: GND -> pin 6
Red: + 5V -> pin 4[/code]

Volumio 1.55
It doesn’t boot. If I replace the boot folder on the microsd card with the files from github/raspberry/firmware it boots. But the ethernet and wifi doesn’t work, if I type ifconfig -a I only get “lo” interface.

Ethernet and wifi work out of the box.

Volumio2 RC1
It boots and ethernet is working. Wifi seems to work, I can enter my WAP2 key, it says “connected” but if I remove the lan cable it losts the connection.
I can access the interface on my pc. I change some things in the settings, access the files from my PC and copy one mp3. But it randomly crashes with this message :

unable to handle kernel paging request at virtual address

If I try to play an mp3 I get the message “cannot decode”.

The goal is to have Spotify on Volumio.

Thank you :slight_smile:

There appears to be a problem with setting wifi in the webUI with the current Volumio RC. I have it working on a RPi Zero with the following /etc/network/interfaces config file:

[code]auto wlan0
auto lo
iface lo inet loopback

allow-hotplug wlan0
iface wlan0 inet manual

You will also need to edit /etc/wpa_supplicant/wpa_supplicant.conf file to include your wifi settings, for example:



where ssid is your network name and psk is the associated password.

This will set up your RPi Zero with an IP address by dhcp. I have yet to find out how to set a static address, and am hoping that this will come with the next RC.