help with stereo to mono options (plugin tried)

Hi ,

I’ve just started using Volumio and I must say I’m incredibly impressed (hat tip to the developer) .

My current setup is a raspberry pi 4 with a hifiberry amp2 and a single speaker driver , output device set as Hifiberry Dac plus and gpio button plugin installed with assigned play and vol up and down .

I’ve so far manage to connect to my Nextcloud storage to play local files ,which works a charm and test out the stereotomono plugin.

Here in lies my problem the plugin does work at downmixing the stereo to mono, but the mixer type then defaults to none and to adjust the volume via the UI it steps in 5 when adjusting the volume and using the gpio buttons I can only raise the volume to 31, I understand this is because it is not compatible with softvol and probably defaults to hardware volume control

This is obviously the same if I disable the plugin reset back to Hifiberry Dac Plus only and have its default mixer type as hardware I can only raise the volume to 31 when using the Gpio buttons and it step in 5’s in the UI.

If use the software as my volume mixer type i can raise the volume with the Gpio button all the way to 100 in steps of 1 and also in the UI .
I’ve read that I could use asound.conf to convert stereo to mono as described here however I’m not sure how well this plays with the existing softvol setup present in the asound.conf file . Of course using software control has its downsides and it does prevent me from potentially using the equalizer plugin but is this my only options ?

I not sure what is the best option available or if there are any other options, but I would be grateful for any help .

thanks in advance .

in fact, when the plugin is activated, it still uses hw mixer set before enabling it, even if it appears as ‘none’ in settings of volumio.
so the problem comes from the way volumio handle your dac. Try to open a console via ssh and type alsamixer. Use F6 to select your dac and check between volume level. One of them should be set at 31. Move it to 100.

Hi Balbuze

Thanks for this I’ll shall have a look tomorrow and post an update on the problem , apologies fo the delay in replying strangely I wasnt notified via email of the reply .

Ok so I have an update on this,

I have the it set to Hifiberry Dac plus , Mixer type as hardware and startup volume 10 , max volume 100 , steps 1 , volume curve natural .

I checked alsa mixer and none were showing set to 31 but I could control the Digital volume with arrow keys and the Gpio buttons however it still stopped at 31 when using the Gpio’s but I could get it all the way up to 100 when using the arrow keys or changing the volume in the UI.

strangely I tried setting steps to 2 and this time i could get it all the way to 89 using the gpio’s but no further and with it set to 4 I could get it all the way to 100 .

I might try a fresh install tomorrow and hope that resolves the issues.

So a fresh install did not remedy the gpio volume issue . I’m a little stumped what to try now .
Currenltly I’ve left it set to step size 2 so at least I can get the volume up to 89 .

Any ideas balbuze?