Help with Snapcast+Volspotconnect2+SPOP for Multiroom Synch

Good evening everyone - new Volumio user here… having a blast with it! So much I built a second client to run in the house :slight_smile: With the addition of the second client, had to give multiroom synch a run.

Am using Saiyato’s snapcast installer, Volumio’s built in SPOP plugin for Spotify and balbuze’s volsporconnect2 plugin. I have Snapcast up and running fine with local music and web radio - server (hostname volumio) and client (hostname volumio2) are in perfect synch. Also, Spotify works fine on both server and client locally via SPOP. Per Saiyato’s instructions I installed volspotconnect2 on both server and client, on the server I changed the stream to volspotconnect2, saved, patched, and saved the plugin to execute. On the client I disabled dedicated stream, set to volspotconnect2 and saved. Rebooted both devices… I can’t seem to get a Spotify song I play in my server to stream to both devices in synch. If I use the Spotify app on my phone I can connect to each device individually remotely - again, not streaming to each other.

Here is the volspotconnect2 config:

volumio@Volumio:/data$ cat /data/plugins/music_service/volspotconnect2/
#this file is generated by the plugin. You should not edit it unless you know what you do. It will be overwrite by the plugin each time a change in config is detected
cd /data/plugins/music_service/volspotconnect2
./librespot -b 320 -c /tmp --name ‘Volumio’ --backend pipe --device /tmp/spotififo

volumio@volumio2:~$ cat /data/plugins/music_service/volspotconnect2/
#this file is generated by the plugin. You should not edit it unless you know what you do. It will be overwrite by the plugin each time a change in config is detected
cd /data/plugins/music_service/volspotconnect2
./librespot -b 320 -c /tmp --name ‘Volumio2’ --backend alsa --device plughw:1 --disable-audio-cache --onstart ./

First question - Any idea why it’s not streaming Spotify to the snapcast client at all, even when I launch on the server via a Spotify IOS app to volspotconnect2? (Plays fine on server, nothing ends up on host) I think maybe the client has a problem with --name ‘Volumio2’, maybe should be Volumio (name of my server, right?) Can’t seem to find where to change the source stream on the client plugin.

Second question - if I play a song via SPOP on the server volumio, will it stream to the client via snapcast, or does it only work remotely from another app like Spotify for IOS?

Sorry for the newbie questions - thanks for your help!

I had a few teething troubles myself to get it up and running. The major thing was re-saving the spotify plugins after I had patched them on the snapcast plugin. It took a few attempts to actually save them but eventually and after a reboot of both devices I managed to get streams from spotify connect in sync on the client and server.

Thanks for the advice, I’ll give it a shot… two questions: did you save the SPOP plugin in addition to the volspotconnect2 plugin after patching? Also - did you patch your client? I thought I read somewhere if you patch the client you can’t play Spotify on that single device.

Thanks for the help!

I only patched the server, but I re-saved the volspotconnect2 and spotify plugins after I patched the server. I think I re-saved on the client and server multiple times, as it was mentioned that it doesn’t always do what it needs to initially.

Thanks again - I’ll give it a shot.


Still no luck - saved both plugins numerous times, rebooted numerous times… still nadda except NAS or WebRadio.

Just a bump… still having the issue. Plugin seems to work fine on the client, I can stream from my phone to the client via the Spotify app… just can’t get the client to listen to Spotify on the Snapstream from the server. NAS/Web Radio multiroom work fine across all devices.

Any other ideas? Thanks for the help…

Seems like someone else is having the same problem and has raised the issue in the github for the snapcast plugin. Hope you can get it sorted soon. … /issues/22