Help with gamma2 + i2s with volumio

Hello everyone, I’ve been using my raspi + volumio + grubdac for a while and love it. I finally finished my gamma2 standalone dac and tested it with a gamma1 board (making sure the board works + i2s works). Whenever I hook it up to Volumio, I can’t ever get sound to come out of the card. I’ve tried the volumio-1.5_wolfson-0.1.img, Volumio1.51PI.img, and just recently Volumio1.55PI.img.

When I load the wolfson image and try to run any of the output scripts I get the error: amixer: Cannot find the given element from control hw:0
The few places I see people solving this issue with with new hardware. The troubleshooting guide here: … Manual.pdf also indicates bad hardware. While I agree I could have messed up the hardware, I’ve triple checked it with a gamma1 and it always works great. I also didn’t forget to bridge JP1 on the gamma2 as per the instructions to run as a standalone dac.

I’ve traced all 5 of the i2s pins from board to board to make sure I didn’t make a connection error, they all pin out just fine.

With the non wolfson images, I enabled the generic DAC and volumio wouldn’t show it was trying to play. Without it it shows playing but no sound. I also tried executing the wolfson scripts under 1.55 with the same error. With the wolfson image it shows trying to play, but no sound output.

Any help would be much appreciated, I’ve read one post about someone getting their gamma2 working with volumio via i2s, but no details on how.

If there isn’t a solution, I can get the wolfson audio dac everyone says works… I’d just really love to use this badass dac I built :slight_smile: