Help with 192khz files

Hello - I’ve been in the Wolfson topic so far and it has gotten me up and running but I have one more problem that I am hoping someone here can help me with. I can’t play 24b/192khz files - they skip and sputter.

I’ve done some trouble shooting and here’s what I have so far.

RPi B vers 2
Wolfson DAC
Volumio vers 1.4 with Wolfson intergration by m3m3
Running through coax output to an Onkyo TX - SR 800 (specs say its dac is 24/192

When setting the upsampling option to disabled - no output is generated at the coaxial (or silence) for songs at 192 (anything lower than than outputs fine)

If I choose any of the options for resampling it will ouptut all lower resolution songs fine.
but the 192 files skip and sputter.

So I can play everything but the 192. Looking at the Wolfson manual it says that "sample rate must be the same as TX is both are enabled concurrently.

TX appears to relate to Pin number 4 “AIF3TXDAT”

Anyone have any idea how to solve this?


Had success and failure with 192 khz on volumio + Rpi.
Had the wolfson dac working on analogue out but haven’t tested coax out for different bit rates.

In order to compare with your case can you specify
-where are source files stored ? Nas, usb drive etc.
-interface to RPi e.g. USB, ethernet hard wired cable, enet wireless
-media controller, web UI, tablet, phone etc.

If you post info then can make some comparative tests with a teac and audiolab dacs.


Hi Kevin

The files are stored on a NAS drive connected to my lynksys wireless router.

Interface with the wolfson/pi is by wireless.

I’m running the volumio 1.4 image by m3m3 that incorporates the wolfson drivers.

I played a bit with the re sampling option and the audio buffer on volumio. At 16 bit 92 I changed the buffer from 2048 x 2 up to 16384. Each time the output played a little longer until sputtering. I jumped from 16384 to 98304 and the card crashed. I re flashed the image to the sd card and I am back to square one.

Thanks for your help.


I’m using ethernet myself, and as you know, I have no problems playing tracks at 24/192. Don’t know if that might make any difference, although obviously most of the data is going via the I2S interface (I’d assume).

I have a coaxial cable running from the Wolfson (in the Pi) to the coaxial input on my CD-Receiver, which also happens to be an Onkyo, the CR-N755.

Actually it does occur to me that although the outgoing data is going via the I2S interface, if the tracks are stored on a NAS connected to the Pi via a wireless connection, you are pulling a lot of data in over the Pi’s USB bus (with tracks at 24/192), which in my experience can be a little flaky. I’ve got my tracks on a USB stick. OK that’s still the USB bus, but it’s not having to go over wireless. Food for thought anyway …

Good comments - I’ll try loading the song onto a stick and see if it can play that way.


Yep good suggestions +1

Will try some testing over weekend or early next week. As i sell hardware and configuration services of these type of devices my rule of thumb is not to attempt >48khz over wireless. I get less phone calls applying this rule :wink:

Will post a bit more related info soon but you should know that on an RPI the enet and usb buses are connected, whereas on a pc, laptop etc. they are separated. When you consider loading on an RPI you can add USB and enet traffic.

Have a nice weekend,


i think this may be the solution. I didn’t get my reciever in the computer room working so I couldn’t try the ethernet direct connection but I did use a USB stick loaded with two high res files. THey shill wouldn’t play with the resampling disabled but would play on everthing other than any selections with 192 as the sampling rate. Definitely an improvement. I’m going to bring home a long cat 5 cord tonight and see if that solves the problem completely.

I saw somewhere that the Onkyo SR800 has a resampling feature itself. I don’t know if there may be some interplay (advantageous or disadvantageous) going on between that and the resampling options in Volumio?

Anyway, it sounds like you are making gradual progress. Probably just a matter of trying every option to get incremental improvements.

Thanks Tyres - Indeed it does - I’m at work but I’ll togle that option when I get home to see if it improves.

Can you tell me are your playing 192 files over wireless , ethernet or what?



Well, the Pi is connected by ethernet to my router (BT HomeHub 4). I connect to the router wirelessly from my laptop or my mobile phone.

If using the laptop I use Volumio to control play (via the wireless connection to the router). If using my mobile phone (Android) I connect wirelessly using MPDroid (again via the router).

So the control functions are via wireless as far as the router. After that presumably they get sent to the Pi over the ethernet cable.

As my music is on USB sticks, no music data is being sent over wireless.

Acoustic Mood & Tyres,

As Tyres states you need to separate the control (start/stop/volume etc.) over network (easy) and the actual streaming i.e source >> sink. Bear in mind with 24 bit 192 kHz tracks you are approaching 10 Mbps bandwidth (16/44.1 is 1.5, MP3 is < 0.5 ).

In my experience with playing 24bit 192 kHz files the most reliable results are achieved in the following order (you stand a better chance with 1 than 4):-

  1. Source (USB Key) >> Sink (Volumio)
  2. Source (NAS Drive physically connected to router, mounted on Volumio) >> Sink (RPI physically connected to router + Volumio)
  3. Source (NAS Drive physically connected to router, mounted on Volumio) >> Sink (RPI WIRELESSLY connected to router + Volumio)
  4. Source (NAS Drive WIRELESSLY connected to router, mounted on Volumio) >> Sink (RPI WIRELESSLY connected to router + Volumio)

Try that long Cat5, hope it does the job. :slight_smile:


Thanks Kevin the cable is on order as we speak.