Help setting up Windows 10 dev environment for UI

I am trying to set a dev environment for Volumio UI under Windows 10. I have followed the instructions here … or_UI.html

When I try to install the npm dependencies I get

[code]D:\Volumiodev\Volumio2-UI>npm install

bufferutil@1.2.1 install D:\Volumiodev\Volumio2-UI\node_modules\bufferutil
node-gyp rebuild

D:\Volumiodev\Volumio2-UI\node_modules\bufferutil>if not defined npm_config_node_gyp (node “C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin\…\node_modules\node-gyp\bin\node-gyp.js” rebuild ) else (node “C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js” rebuild )
Building the projects in this solution one at a time. To enable parallel build, please add the “/m” switch.
MSBUILD : error MSB3428: Could not load the Visual C++ component “VCBuild.exe”. To fix this, 1) install the .NET Framew
ork 2.0 SDK, 2) install Microsoft Visual Studio 2005 or 3) add the location of the component to the system path if it i
s installed elsewhere. [D:\Volumiodev\Volumio2-UI\node_modules\bufferutil\build\binding.sln]
gyp ERR! build error
gyp ERR! stack Error: C:\Windows\Microsoft.NET\Framework\v4.0.30319\msbuild.exe failed with exit code: 1
gyp ERR! stack at ChildProcess.onExit (C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\lib\build.js:258:23)
gyp ERR! stack at emitTwo (events.js:126:13)
gyp ERR! stack at ChildProcess.emit (events.js:214:7)
gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:198:12)
gyp ERR! System Windows_NT 10.0.16299
gyp ERR! command “C:\Program Files\nodejs\node.exe” “C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js” “rebuild”
gyp ERR! cwd D:\Volumiodev\Volumio2-UI\node_modules\bufferutil
gyp ERR! node -v v8.9.4
gyp ERR! node-gyp -v v3.6.2
gyp ERR! not ok

I have installed the .NET Framework 2.0 SDK. The only problem I ran into is that I tried the 64 bit one first and it just would not even try to install (even though the machine is 64 bit), so I installed the x86 one - successfully. Still the error suggests it is not installed?

I remember the same problem, but I don’t remember anymore what I did. I’ve since set up the development environment on Fedora (mostly just out of interest). Most folks here (and the JavaScript community in general) are more Linux oriented, which is why you can generally expect fewer issues if you do likewise.

If your main interest is Visual Studio Code, that runs just as well on Linux as it does on Windows.

I’ve got rather detailed instructions for setting up the development environment on Fedora if you’re interested. Sorry I can’t help anymore with the issue under Windows.

Thanks for the reply. I have been hitting my head against a brick wall all morning. vcbuild does not seem to exist any more, but found it in an old version of VS. Still would not work properly, then I found this

npm install --global --production windows-build-tools

Fixed the problem for me just now. VS not required.

Yup, that was it for me too back then :wink: