Help installing plugin from zip

I am afraid I’m missing something elementary.
I want to install the Saiyato’s volumio-snapcast-plugin. The install directions say “drag and drop” the zip file, which doesn’t make sense to me.

I tried cloning the repository /home/volumio/repositories folder and then running the ./install.sh, but I did not see the plugins on reboot.

According to the volumio manual,
volumio.github.io/docs/Plugin_S … rview.html
I should be able to install a plugin via the volumio UI. (Perhaps this is what is meant by ‘drag and drop’?), but if I click on the plugin menu on my volumio, I see two tabs.
One says ‘search plugins’ and then has multiple categories below it. (BTW, because there’s no search box available, it seems like this is really ‘browse plugins’.) The other has a list of all of the plugins installed on my volumio, but I don’t see the snapchat plugins and I don’t see how I can point the UI to a file.

WHat am I missing?

hi,

the volumio manual is not uptodate. with one of the latest updates the point install from zip is blown away, a political thing or so.

installing plugins from zips are possible:

  1. unzip the plugin in a new directory
  2. ssh in this directory volumio plugin install

greets

Just to clarify things, in the past it was possible to install unofficial plugins by dragging and dropping zip files into the Volumio UI. This behaviour is no longer available (you can read about the discussion here), and plugins have to be submitted for review, before they appear in the Volumio UI ready for download and installation.

Thanks for your replies. To be clear for those wanting to install an unofficial repository.

  1. SSH into machine
  2. Download zip using: wget
  3. Uncompress in new folder
  4. Run: volumio plugin install
    Note: no need to use sudo and plugin is not customized for your plugin, it is literally ‘plugin’.
  1. SSH into machine
  2. Download zip using: wget
  3. Uncompress in new folder
  4. Run: volumio plugin install
    Note: no need to use sudo and plugin is not customized for your plugin, it is literally ‘plugin’.

i think this should work!

for linux noobs

  1. download plugin volumio-plugins-collection-t6251-10.html#p35125
  2. unzip the .zip / ftp to volumio / create a new folder / move the unziped files in the folder
  3. ssh into the machine
  4. run: volumio plugin install in the new folder

I do not know if the place of the new folder is relevant (new volumio updates eg). I just can not look, I have the bubbleserver-plugin installed under … data / plugins / service / bubbleserver

my opinion for removing the point install from zip (UI):
the possibility is nice / volumio plugin install. But
I think if a user needs a plugin he will try to install it. the biggest mistake is human and sits in front of the system. minimize the human error source and save a lot of time support! These are my experiences after 7 years of development and support !! everything that can go wrong will go awry.

produces an error “not in the directory”, can not install on ssh

@Fedor_Milkov
You have to be in the folder where the files from the zip have been extracted to. From there run volumio plugin install

I think I have the similar plugin upload/instead problem. I have install 2.368 Rel Sun Feb 18 but when I tried to install Plugin, there isn’t a tab for me to do file upload (see attachment). I searched Youtube regarding Plugin install, all of them have the Upload tab under Plugin function.
Please help
1.gif

You don’t see an upload tab anymore because the option to install plugins by drag ‘n’ drop recently has been removed as chsims1 stated above. His post also provides a link to the discussion regarding this move.

THX, it was not to easy to understand. But now it works.
My Display is alive. An i can see the informations.

Unzip doesnt´t work on Raspbery pi at me. I used winscp. Download zip to windows an unzip. Then i pushed the unzipped files to pi to plugin Ordner. then install the plugin. as you describbed.

Interestingly, the JUSTBOOM version of volumio still has the feature to upload/install a plugin via drag’n’drop.
IMG: pisupp.ly/justboom-player

Has pretty much the same other features.
After a while of battling with volumio and KODI, i reverted back to JUSTBOOM only to find there was an update 4 months after i initially setup my own.
:confused:
This has pretty much the same features as the latest volumio img (inc the repository that “they” insist we use) only with the beloved “upload plugin”
Even more interestingly, when i performed a full system reastore, it diverted back to the volumio skin. But WITHOUT the beloved “upload plugin”.
So had to perform a whole IMG press to get it back.
Its in there kids, Somewhere

The most recent voluimio build to date does not work with the KODI plugin and I2S HATs. It was only from going through this route i could get everything to work.
Hope this information helps someone :wink:

I have a fresh copy of volumio and I’m trying to install some plugins from zip.

I downloaded and un-zipped plugins, then in plugin folder I run “volumio plugin install”.
It would fail because of the permissions writing into /tmp/…
If I run using sudo “sudo volumio plugin install” it always hangs either at downloading plugins or creating folder messages.

I’m I missing anything? I’m physically connected to rpi 3 b+, not via ssh.

Have a look at https://volumio.github.io/docs/Plugin_System/Plugin_System_Overview.html :wink:

the instructions are exactly what I’m doing

here is error I’m getting when following these instructions:

Compressing the plugin
Plugin successfully compressed
/bin/mv/: cannot stat *.zip: No such file or directory

any idea what can cause the issue?

Have you changed the default password in volumio?
Are you sure to type exactly the command as described in the help doc?
Have you tried with an other plugin?

Have you changed the default password in volumio?
No
Are you sure to type exactly the command as described in the help doc?
Yes
Have you tried with an other plugin?
Yes, I cannot install any plugins

What is the output of ls right before you perform the volumio plugin install step?

My 2 cents: manual plugin install should be discouraged as much as possible for non developer users.
We want plugins to be submitted to the plugins repo, to make life easier to everyone.

If manual plugin install do not work, then (IMHO) people should figure out themselves as it will take ages to know what’s wrong without knowing which plugin it is…

I’m within unpacked plugin folder.

volumio@volumio:/data/INTERNAL/plugins/volumio-minidlna-plugin-master$:ls
install.sh, [and other unpacked plugin files]