Help impossible to install plugin

Hello everybody,

I have a problem with volumio, it’s impossible to install plugin. When i try I have an error and it’s the same for all plugin.
Before, it was possible because i have several plugins.

This is the second time i have to reinstall volumio to install plugin :confused:

Help me !

what is your device ? volumio version?
What plugin?
How do you install it?
What is the error ?

I have the lastest version of volumio with a raspberry (8go card).

I have :

Touch display
Squeezelite player
Spotify connect
Youtube playback

I tried to install several plugin but it’s always the same (70% ) :

Installing dependencies
The following error occurred when installing the plugin: Error

I saw something else today, I tried to do a playist and when i put my music in a new playist, after it was not available in this playist.

What is the minimum config for the SD card ?

You need a internet connection to install a plugin allowed to access Debian repo and github.
Maybe something is corrupted on your SD card. Have you tried to reflash?
No problem using a 8gb SD card

I have a connection, i have the wifi on my volumio.

I have already do that, but after several days it was the same.

This is not a problem with volumio ? Somebody has something like that with volumio ?

Maybe my sd card ?

Possibly a DNS issue.
Can you test if you can play some web radios?

yes it’s possible to use web radio.

a DNS issue ? can you explain me ?

if you are familiar with typing commandline instructions, we can diagnose further:

  • enable ssh from /dev page
  • connect from your computer to Pi under ssh; you may use Putty under Windows. (user/pass: volumio/volumio)
  • type: wget -q --tries=10 --timeout=20 --spider and report results
  • type: sudo apt-get update and report result

I had a similar result when trying to install a plugin from a new install.
Checking the details revealed that dpkg was configuring the keyboard and waiting for a response to select the default layout… which was not possible from the web UI.
My solution was to ssh into volumio and force a continuation of the install…

ssh etc
sudo su
apt-get install -f
This will probably give a message about a failed configuration of the keyboard and you will need to configure the keyboard correctly
dpkg-reconfigure keyboard-configuration

Once configured, try re-installing the plugin from the web UI.

macmpi :

for the first line : wget -q --tries=10 --timeout=20 --spider
I have nothing

for the second : Fetched 17.9 MB in 37s (481 kB/s)

Greythane :

I have the keyboard on volumio (chromium)

ssh etc.
ssh: Could not resolve hostname etc.: Name or service not known
$ sudo su
[sudo] password for volumio:
root@sdb1:/home/volumio# apt-get install -f
Reading package lists… Done
Building dependency tree
Reading state information… Done
0 upgraded, 0 newly installed, 0 to remove and 47 not upgraded.

ok, so Internet and repo accesses seem fine.
You may try to install a plugin again, and send a log (check doc in my signature) for analysis.

Maybe the keyboard. I going to try to reset with volumio,

I would like to have a keyboard because I have a screen but if it’s the problem, I going to give up the keyboard.

It’s not a problem, just a different way of accessing Volumio at the command line. You can either do it directly with a screen and keyboard (as you appear to have), or remotely from a different computer using ssh.

Yes I understand that, but maybe this is the install of the keyboard which slow down volumio

I had the Problem installing the Touch display plugin while a keyboard was connected, it always stopped at 70%. It worked when I removed the keyboard, but now the plugin is not listed as “installed”, which is why I can’t install the updates.