HDMI-out problems on ASUS TinkerBoard

I am very new to Volumio.
I have installed it on my TinkerBoard, everything works fine if I connect it directly to the TV (I had to enable software mixer in order to control the volume).
When I connect it to my HDMI-switch problems occur:

  • Audio and video does not work
  • If I try to use the switch as an audio splitter to toslink it does not work either
  • I tried the same tinkerboard with lineros (asus linux dist) and it works fine via the switch (audio does not work though, but that is a seperate problem)
  • My rasberry pi 3 works fine both video and audio (and audio splitter)
  • My chromecast works fine both audio and video through the same switch
  • I have used the same cables for all tests (so I dont think it is the cable)

My guess is that somehow the switch reports back something to the tinkerboard that the drivers does not like. Maybe it is something with the switch not supporting 4K but the TV and Volumio does?
I find it strange that Chromecast, raspberry pi and Tinkerboard (lineros) works, that would imply that something can be done.

Since I installed everything with the TinkerBoard connected to the TV I figured that it might be some setting that is set in the initialization phase so I reinstalled Volumio and installed everything connected to the switch instead. No image or sound worked.

I dont know how to debug this further
The log can be found here: http://logs.volumio.org/volumio/hU2ywqk.html

Ideas are super welcome!