HDMI audio not available with Volumio 3

After a failed upgrade von version 2 to version 3, i did a fresh install on a RasPI 4B.
Amongst others, the main issue is that HDMI is not available as an output device. Only ‘headphones’ is available:

I don’t have a DAC attached to the PI, only the RemotePI (Plugin is installed as it was on Version 2).

I checked already /boot/config.txt. It contains already hdmi_force_hotplug=1

It used to work with version 2 and I cannot recall to have made modifications to make it work. As far as I remember, it used to work out of the box.

Any ideas wher I could look?

Do you have the touch display plug-in installed?

Yes, the touch display plugin is installed and enabled (as it was before with version 2).

@gvolt do you know if he need some settings to See it ?

Connect to Volumio via SSH and try adding


to “/boot/userconfig.txt”.

1 Like

Thanks - I’ll try this evening as I’m in the office now.

This did not help. Headphones is still the only option which is available.
This is my config.txt:

initramfs volumio.initrd

include userconfig.txt

This is my userconfig.txt - didn’t change anything by hand:

# Add your custom config.txt options to this file, which will be preserved duri$

#### RemotePi lirc setting below: do not alter ####

Ps you can beter add it to userconfig.txt instead of the config.txt
Config.txt can be overwritten by the system.

What device is connected to the HDMI port and which of the two HDMI ports of the Pi do you try to use?

The device is a Marantz NR1710.
Not sure about the port no. - I use the one next to the power line.

The amp recognizes the PI. It selects the input automatically when the PI is powered on.

I’ll try the other port though. But I don’t think it will change anything because it is not shown in the selection at all.

That’s HDMI0. You can stay on it IMHO:

Do you also have a display connected (DSI, SPI…)?

On my Rpi4 + official display, no hdmi option available :thinking:

Yes. I have the official 7" display attached and the RemotePI board.
As stated above, the touch plugin is installed and enabled.

I have a DAC board here but there is not enough space in the housing, that’s why I’d like to use HDMI as with the version 2.

Someone mentioned here that removing pulseaudio did help in some cases:

sudo apt update
sudo apt -y purge "pulseaudio"

Is is worth trying or does this break the installation completely?

I don’t think so. Instead try adding


to “/boot/userconfig.txt”.

That worked - thanks!

Here is my new userconfig.txt. Hope that this helpes someone else:

# Add your custom config.txt options to this file, which will be preserved duri$


#### RemotePi lirc setting below: do not alter ####

The line


was removed from config.txt and is now also in userconfig.txt.

With HDMI0 connected to a Denon AVR I just tested without “hdmi_drive=2” and it worked, too (just with “max_framebuffers=2”). When using an HDMI display (TV) that is to play audio, “hdmi_drive=2” may be required though.

1 Like