Have problems to install volumio on SSD (x86 NUK)

Hi All,

Good evening!!

I tried two methods I’ve learned from the forum to install the volumio on the SSD (Samsung 970 Pro, NVME) in my x86 NUK. Below is the link that showed steps I followed, but got no luck.

Trial (A)
I followed every single steps above with a volumio bootup USB drive and another USB drive (FAT32) with the volumio image. After the zip file was unzipped (I believed it’s been unzipped on the Samsung SSD), then I “umount” the USB drive and powered it up, the system brought me to the “shell>” mode. I tried several times still failed.

Trial (B)
I read from the same thread that some users got their systems up running from a Windows 10 environment. I followed to install a Windows 10 on the Samsung SSD (FAT32, NVME), then booted up the system with a volumio-ready USB drive, from the user interface, there’s a build-in function that allow user to install volumio directly to the HDD, which is the Samsung SSD. However, I encountered the similar problem, that the system should have been installed, but the volumio still couldn’t be booted up without the USB.

Specs for my x86 NUK are listed below:
Intel NUC i5 10xxx
Samsung 970 PRO SSD
Crucial 8GB X 2

Could you please help to show me what the problem is? Compatibility issues or hardware issues? Any comment / help is greatly appreciated!!

Mike

Assuming a HDD Install is the same as a SD in a Pi, you don’t get a gui from the device it’s self, you have to access the machine from a web browser, so I assume you may have been ok on Trial A

Before I powered up the NUK again, I checked all USBs had been unmounted, then I press the button to turn on the NUK, the scripts ran along and finally it brought to me a command line mode with “Shell >”, stuff like that, and then I got stuck there, so no chance for a gui or so for me to access the NUK from a web browser… that’s for Trail (A).

Thanks Andrew, with your inputs I can explain more in details where I got stuck, hopefully someone had similar experience can show me the way!!

Cheers,
Mike

you could start with taking a picture of the screen, I think it does not boot properly. And also give the complete NUC type, 10xxx is not very helpful.

Edit: could you also write which volumio version you have used?
The one from the download page?

The PC version has a UI out-of-the-box

In case you have a newer NUC, try this Alternative new hardware beta version

Sorry for my late reply, thanks for that and I will give a shot!!

Many thanks,
Mike

How do you install this? Do I do the Trail a or b from above?

Hi park13:

Finally the problem was caused by the Samsung SSD (nvme), the Samsung SSD has been replaced with a crucial ngff SSD, then the volumio can be installed successfully.

Cheers,
Mike

Curious why this will not work with Samsung SSD?

Did this work? I would hate to have to buy a new SSD?

The Samsung I had was a “nvme”, I am not sure what it is, you can google it, but that nvme version SSD didn’t work, then from somewhere I heard that there’s another version called “ngff”, then I ordered one and got the volumio installed.

Yes it works on mine, hope that help you as well

Cheers
Mike

nvme devices are supported in our alternative version mentioned many times above.