Has anyone tested Volumio on the Cubox-i yet?


I can’t make the mod work for me to add the ALSA USB support. I have tried plenty of times…
Volumio is running fine and I can add music from my NAS, add WiFi, Play music but no sound to my USB DAC.

If I write “aplay -l” just get “aplay: device_list:252: no soundcards found…”, if I look in Volumio I have SPDIF and HDMI
but no more. My image is the one found instructions for here: solved-wifi-cubox-t1117.html

Hoping for some guidance.

(( Phi

P.S. I am a beginner on Linux, but I have had Raspify up running RPI and after that Volumio and before that
MPD Voyager on another platform.

Are you using the build from the first post in that thread? The second post in that thread is from me documenting that the OP’s build disabled my USB DAC - the same DAC that worked when I used the default beta build. And two other posters reported the same thing. So IMO, you’d be lucky if that build worked for you.

IMO you’ve got two choices… using the default cubox-i build, as found on the Volumio website. It appears to work fine with USB DACs. Then apply the USB drive fix - if you need it. But using the default build means no wifi.

The other choice is try Berrington’s build. I can’t recommend it, only because I haven’t tried it yet. But that too, might be your solution.

Please allow me to amend that last post. Clearly had my facts mixed up!

Brerrington did not have a build, but rather identified a fix that got USB DACs working on Istein’s build that phi linked to. And I can say that for me, the fix did work. Or - at least - I can confirm that it fixes the aforementioned problem with USB DACs not being recognized.

So clearly I was mistaken phi! Apologies. My direction was incorrect.

That said, having applied the Brerrington’s fix, and another fix get USB drives working, to Istein’s build, now I can’t get WiFi working. Going to have to go dig into what the problem may be…

Hi Scrolley,

Thank you for trying.

Hardware wize I have Cubox-i2 and the Mircro SD card that I bought with it from Solid-Run, a slow Transcend speed class 4 card,
loads image at about 4MB/s. I have after that bought a high speed SanDisk that loads the image with 16MB/s. (I know it’s write
speed, not read speed, but there is correlation).

  1. Original Volumio with any of the SD-cards doesn’t work for me at all.
  2. Istein release work with the higher speed SD-card as far as Volumio is up running and WiFi works, BUT alsa USB is not there.
  3. The Berrington fix for the alsa USB doesn’t work. I suspect something more basic is wrong somewhere, but that is just a feeling.

I think I will have to sit down and wait for a new release from Michelangelo and hope it works for Cubox-i2 this time…

(( Phi

Hi all
I have been testing volumio for some time and I like it a lot.

My key objective is to create a UPNP Renderer with WiFi connection.
I am using Cubox-i2. WiFi stick is Edimax EW-7811UN (RT-2870 chip). My UPNP server is Jriver MC19 running on a Windows PC. DAC is a USB dac based on XMOS chipset, capable of 192-24.

I have tried the above setup with Squeezelite, running over Geexbox distro - works perfectly.

I have tested so far:

  • version 1.4 official beta - doesnt boot.
  • version 1.4 beta cuboxi - runs well, UPNP works nicely (tested with 192-24 files, both FLAC and M4A), wifi doesn’t work, airplay works but makes horrible sounds.
  • version 1.2beta, with upgraded kernel - boots ok, wifi works well, UPNP doesnt work, MPD shows USB dac but doesnt make a sound.
  • Eventually, I found a patched Kernel for cubox-i, that supports wifi as well as other features, and this is it - Volumio V1.4 beta-cuboxi, with Kernel 3.10.48, and everything works perfectly !

Please keep up the good work, I’m a fan already !
Thanks, Yair

I have set up a cubox-i2 with Volumio 1.4, to stream Qobuz content from my Android smartphone via airplay. The cubox is connected to my A/V receiver via SPDIF. That works so far. But the output volume is far too low. Does anybody know how to adapt the mpd.conf? Changing the mixer options in the Volumio UI didn’t have any effect.

Airplay under Volumio 1.5 didn’t work (only noise is transmitted).
I still have to install the appropriate driver to get Wifi working under 1.4 (next weekend).

Until now I used Archlinux with Logitech Media Server and Squeezelite with the Qobuz plugin: good sound but sometimes unstable playback. That’s why I’d prefer Volumio as airplay receiver.