Hardware volume control not recognized after update to 2.668

after updating volumio to version 2.668 yesterday I lost control over volume. And I also cannot pick Hardware under mixer type. Any ideas how I can solve the problem?
So far it worked well for 6 months.
I did a reset already.
Please advise.

I can confirm, the same happened to me. Unable to select either software controller or hardware mixer since update.

Today I updated again to new volumio version 2.671. I hoped that this problem with volume control will be removed with the new upgrade but it is still present with the new version.
Why this bug happens only to few users?
Is there a hope for me that there be will be an update in the future that will repair the volume control?

I gave up and did a factory reset, followed with updating to the latest version, everything works again as it should.

cool thanks. Is it possible to do the back up of the current settings, playlists, etc.?

@keramik, you could try to install the “Backup & Restore Plugin” to make a backup before resetting to factory defaults. It will create a volumio_data.tgz file on root of SMB Share. make a backup of it, reset to factory defaults, update and restore the file to the original location if it was deleted, reinstall the plugin and restore your settings.

Do you have the volsimpleequalizer plugin installed?
It happened to me and I solved it by deactivating the plugin, restarting it and turning it on when it started.