[Guide] SMB/CIFS shares in Volumio 1.5

Many people experienced issues with SMB/CIFS shares in Volumio, so I want to try to suggest a series of steps to follow to correctly configure them.
This guide is NOT useful if you are using NFS. Check also step 14).

  1. Find out the correct IP address of the SMB/CIFS server. You should already know it (typically it begins with 192.168.0. or 192.168.1. or 10.0.0.), but to be sure you can verify it in this way:
  • in Windows open a new Explorer window and in the address bar write: “\IP_ADDRESS” without the double quotes and replacing IP_ADDRESS with the IP address of the server.
  • in OS X go to the Finder, press Command+K (Command is the key with the four lobes or with the Apple) and write in the address bar “smb://IP_ADDRESS” without the double quotes and replacing IP_ADDRESS with the IP address of the server.

In both cases, you may need to enter username and password.
If the address is correct, you will get a list of shares with their correct names. Write down the one you need. For example, I thought my share was called “Music” but it was instead called “music” and this made me lose several days trying to get Volumio right.

  1. Restart Volumio.

  2. Go to the WebUI -> Menu -> Library

  3. Delete all the shares that are not working (like the ones you created while trying to get it to work), but leave the ones that you already successfully configured.

  4. Add a new share

  5. give it a meaningful name (not “NAS”, for example), select protocol SMB/CIFS, insert the IP address you verified to be working, and in the “remote directory” write the name of the share as appeared in the list you saw in step 1). Enter also username and password in the fields.

  6. Save and go to the “Browse” pane of Volumio. You should see “NAS” in the list and, inside it, the SMB/CIFS share you just configured.
    Inside this share you won’t see anything because Volumio needs time to index its content, just give some hours.
    If after some hours you see the files, then you can post here in this thread the type of server you are using and the operating system of the server, including the version. For example, “Synology DSM 5.0, working with default options”. Of course, if someone else already posted your configuration, don’t bother.

If Volumio locks and is not responsive anymore after step 6), probably something is wrong.
In this case,
8) restart Volumio (probably you have to take out the power)
9) like 3)
10) like 4)
11) like 5)
12) like 6) but go to “advanced options” and in the “Mount flags” put the following text: “ro,noatime,sec=ntlmv2”
13) like 7) but, if it is working, post here specifying the mount flags you used. For example “OmniOS r151008, working with ro,noatime,sec=ntlmv2”
14) if you still have problems, DO NOT ask here (your post will be deleted without warning), but start a new thread in the section “First Start Troubleshooting”.

Hint: if you see your configuration listed here it means it is working for someone and you are probably making a mistake somewhere in the steps. Check the correct IP, the correct name of the share (case sensitive), the correct username and password.

Explanation of the advanced options:
“ro” means read-only, it is an added security and safety measure to avoid the files in the server to be modified in any way or deleted.
“sec=xxx” where xxx is ntlm, ntlmv2, ntlmssp is the authentication method, how the server checks if Volumio is giving the correct password. ntlmv2 is the newest, safest, suggested method. the other two should be equivalent and are an older and superseded way of authenticating.
“noatime” means that access times on the server are not modified, in other words the server doesn’t keep track of the last time a file is read by Volumio. It makes sense especially when read-only is used. Otherwise no change of performances or any other effect is produced.

This post will be updated if new information becomes necessary.

OmniOS r151010, working with mount flags “ro,noatime,sec=ntlmv2”

It should be working with the same settings also on any OmniOS r151010 or older, on OpenIndiana 151a8 or older, Solaris 11 or older.

Thanks Lag-na very useful indeed, grazie! Marked as sticky (guess what you wanted to do as well)

When using a SMB server running on OS X, the following advanced options are suggested (to be tried in order and stop as soon as one works):

sec=ntlm
sec=ntlmssp
nounix,sec=ntlm
nounix,sec=ntlmssp

Any of the previous sets of options can be modified by adding

ro,noatime

in case you want to be sure that the files on the server are not touched in any way.

Thanks very much!

this here: “sec=ntlmv2” add to the box in the web ui did it for me!

As written in the first post, the configuration of the server (operating system and Samba version if you know it) must be written to help other people. The parameters used alone are not enough.

Thank you Lag-na. :smiley:
This option worked for me :

nounix,sec=ntlmssp

Mac Os X 10.10 Yosemite.
Volumio 1.5 Cubox i

Which Mac operating system? which options were used in Volumio? the standard ones I suppose?

I’m sorry, but is it possible to somehow make a new IP for volumio-player, network access remained the same \ without changing the settings?
Thank you!

I ran into a problem with mounting a CIFS-mount: everytime I could not see the contents of the disk/partition after mounting it. The update process was finished within a second or so. No files to be seen (strangely I could do a search and then I found the name of a group or album or track, but I could not access any of them).

I checked the mount under /mnt/NAS and saw that the user/group of the mounted directory was “pi” and the permissions were “700” for all directories and “600” for all files. Via grep I saw that this was User ID 1000. I remembered that this is my local User ID on the system where I advertise the CIFS-mount from.
I went to the mount options in the Library settings and clicked on the “show advanced options”. In the options “Mount Flags” I added “,uid=106” at the end (106 is the User ID of mpd in Volumio). After clicking the Save Mount the mount succeeded and the Updating icon started to spin. Now all my music is visible !!! :smiley:

i using for music folder chmod 777
its all )

Hi all this is my first post.

I am kinda new in audiophile but for sure computer savvy and music lover (rock).

In short my setup is:
Raspberry pi B
Volumio 1.55
PMA-50 Denon (USB-DAC)

The idea is to play the music stored in my Windows 10 laptop by sharing folder.

Volumio then mounts it as a NAS and bingo! As long as my computer(or my girlfriend’s) is on we can playback our music libraries by using Pi/Volumio as a perfect hub.

No media stored in the Raspi and no dedicated NAS server.

The problem is Volumio does recognizes all the song of my small FLAC/MP3 library…

  • The browser tab sometimes recognizes all the folders but some of them empty.
  • The library tab only shows the folders that are not empty in the brower tab.
  • Both windows and volumio’s file system recognize ALL the folders and files :-s

The mount flags are: ro,dir_mode=0777,file_mode=0777

I have tried the ones found here in this post already.

Does anyone have clue what the problem could be?

Thanks,
Victor

its bad, :laughing:

For all the Italian Volumio user, with VDSL2 internet connection (telecomitalia), that would mount a flash drive on the USB port of the Technicolor router, this is the solution:

router VDSL Technicolor AG plus VDNT-S
raspberry PI 2
DAC PCM5122 I2S HAT 32bit/384kHz

Source name: as you want
fileshare protocol: SMB/CIFS
IP address: 192.168.1.254/Disk_a1 (or Disk_b1 if used USB2)
Remote directory: – keep empty –
Username: admin
Password: ********

advanced option

Charset:UTF8
Rsize:8048
Wsize:8096
Mount flags: ro,sec=ntlmv2

Don’t add noatime on the option because the mounting will fail

How to delete wrong @profile@ for shara?

after some Troubleshooting i got it to work

i had to disable “secure Login with Password” in Windows to Mount my share.
in volumio i had to enter username and Password (only worked after disabling it in Windows!!!)

using:

volumio 2
pi b+
m-Audio fast track pro
running 24/7

android Smartphone
mpdroid for searching database and coverart
chromebrowser for local webinterface

dedicated Windows 8.1 dj machine
Traktor Audio 6
akai lpd8
mini itx
usb Monitor
Network share of 3TB flac library
configured so dat my pi can Access data also in sleep mode

Router FRITZ Box 7490

IP address: 192.168.178.1/fritz.nas/[Your USB-HD, case-sensitive!]

Remote directory: [EMPTY]

Delete the Mount flags and just add:
sec=ntlmv2

Hi all,

I’m fairly new to volumio so I’m trying to figure thing out. This is how I managed to mount a disk shared from OS X using SMB/CIFS.

OS and Hardware

  • Mac Os X 10.10 Yosemite on an iMac mid 2010 sharing the drive I wanted to access.
  • Volumio 1.55 on a Raspberry Pi 2 B

Working mount flags:

sec=ntlmssp
ro,sec=ntlmssp

Non working mount flags:

ro,noatime,sec=ntlmssp
sec=ntlmv2
ro,sec=ntlmv2
ro,noatime,sec=ntlmv2

work in volumio 1.55
these are no longer working on volumio 2 (the current version)

the following is for windows
you have view/mount options

1) to mount with a drive letter
you need to mount the different folders (ie usb music, ram play.) this will work with software that cant access network locations
use the following locations with the map network drive wizard

\\ip-to-volumio\USB Music \\ip-to-volumio\NAS Music \\ip-to-volumio\Ramplay \\ip-to-volumio\WebRadio
any other custom folders would be here as well
i could not mount the volumio root folder

2) without a drive letter however you can mount the root folder
use the add a network location wizard
make sure you select custom network location
add the following location

\\ip-to-volumio\\

yes thats 2 sets of 2 back slashes

3) without a drive letter as a simple shortcut
right click on your desktop (or in any folder)
hover over new click create shortcut
type

\\ip-to-volumio or \\ip-to-volumio\

i would love a way to mount the root folder as a drive letter but i have not been able to. any ideas how.

also when i say root im not talking about the linux root folder, i mean the network share root.

On my Fritz Box (7490) (running FRITZ!OS 6.x) I succeeded with the mount flags “ro,sec=ntlmv2”.

By the way, the “noatime” option was reported as unsupported option. You can find this out by doing an ssh and trying to mount your share from the command line using "mount -t cifs -o username=foo,password=bar, /// ". If it fails with an unsupported option error, call “demsg” to see which options caused the trouble. And if you are able to mount your share on other linux distro like raspbian for example, just call “mount” to learn the correct option, then you can use them in Volumio as well.