[GUIDE] Improve Rpi hardware performance

Update the config.txt file to fine tune the RPi-3

Go to the boot directory and find the file config.txt
sudo …/…/boot
sudo nano config.txt

Use the arrow key to find the end the line


Save then reboot

Under/Over clocking as well as Under/Over voltage settings are nothing new to computer audio for ARM as well as x86 computers. Archimago struck a good balance with the RPi so they were used with this…however more extreme settings can also give good results.

See Archimago’s blog here: archimago.blogspot.com/2017/01/m … s-usb.html


Hi Dynobot.
your improvement guide’s sounds great, but may seemed not really trustworthy to me because there are no specific information to the RPI.
is the guide for all RPI’s the same? (2,3, zero, zero w, …)
If they are really improvements, why not put them into the next build?
greetings, judydudi



hi dynabot,
are these setting your own, already checked by you? So, do you feel a difference?
Are the settings taken from the web, so a source link would be fine.
thank you. judydudi

LOL, this reminds me of just the other day I offered to a coworker to try Fedora Linux on an old PC he had.

I don’t think it’s the same at all.

  1. Are you sure it’s /boot/cmdline.txt that you want to edit, and not /boot/config.txt ?
  2. These instructions look a lot like the ones given by Archimago. He, at least, offers his rationale for each of the settings he suggests modifying. “Improve Rpi hardware performance” isn’t meaningful, unless you spell out what the word “improve” means.

Thank you prof. The link gives me information to understand, follow the point.

I tried the Archimago link sometime ago. It is fine to play pcm (not really noticed any SQ improvement tbh) and getting drop outs on DsD.

Not surprising.

The whole point of Archimago’s modifications is (contra the original poster’s characterization) to decrease the “performance” of the Rpi (thereby decreasing the power consumption and — possibly — the noise). If you’re using the BruteFIR plugin, or processing DSD audio (or anything else processor-intensive), decreasing the performance of the Rpi is the last thing you’d want to do.

I added a little user friendliness to this to be able to turn this setting off and on easily.

Navigate to

sudo nano ~/.bashrc

Scroll to bottom and paste this code

[code]# CRAAP Tweak
underclock_craap () {
sudo printf ‘%s\n’ “”"" “arm_freq=800” “sdram_freq=400”
“core_freq=400” “gpu_freq=300” “ver_voltage=-4” “over_voltage_sdram=-4” >> $config_file

craap_off () {
if [$craap_button=0 ]; then
echo -----CRAAP Settings are alreaded disabled-----
elif [ $craap_button=1 ];then
sudo sed -i ‘/arm_freq=800/,/^$/d’ $config_file
sudo sed -i ‘/^$/d’ $config_file
echo -----CRAAP Settings Disabled-----

craap_on () {
if [ $craap_button==1 ]; then
echo -----CRAAP Settings are already enabled-----
elif [ $craap_button==0 ]; then
echo -----CRAAP Settings Enabled-----

CTRL + X to save; Y to confirm, ENTER to exit


. ~/.profile

Now you can turn on these settings by typing in “craap_on” or disabling with “craap_off”.