Getting Volumio Running on PiBang distro

Hi all,

I’m a professional software developer and studied as a Sound Engineer, I Discovered Volumio in the past week and I’m hugely impressed!
I’m a little concerned that the developer seems to be a bit quiet of late so I took matters into my own hands! :wink:
Yesterday I decided to see if I could manage to get Volumio running from scratch via a hugely optimised distro called PiBang which is based on Debian. I used the ‘server’ version and I’m pleased to announce that I got it working (with much trial and error) entire installation takes less than 900 MB.

Is anyone interested in a tutorial? it’s basically a case of installing PiBang to sdcard, setting up the software and git cloning the Volumio Webui. It obviously needs a bit of work, but it mounts the USB drive, updates the mpd library etc etc. (currently listening to my Volumio/PiBang tunes as I type)

If there’s any interest I’ll get a tutorial written up.

I’m really interested! And even if I’m silent I’m working hard on Volumio…
Really interested in PiBang also, could you tell me something more about that?

I’m interested too. Always interested in optimizations (and learning).

OT & @Michelangelo: Is there a reason there is no link from to RPi beta 1.2 on sourceforge?

Hi Michelangelo, good to see you :slight_smile:

PiBang is a lightweight cut down version of Raspbian, designed as an alternative to the minimalism of Arch, as such it’s very lightweight but far more stable than Arch.

Please bear in mind that I’ve only had my Pi for two weeks so I’m fairly new to the world of Linux but I’ve learned a lot with this mini-project. I’ve written an install script that will take a fresh install of PiBang server to a working volumio ‘clone’. Planning on writing a blog post ‘tutorial’ about this soon (possibly even later today!)

OK, I’ve finished up the blog post. You can find it here - … io-pibang/
any and all feedback appreciated!

Thanks Ebsy!

…here goes the rest of my weekend… :wink:


I read your blog post. Interesting stuff! I was curious. After installing the web ui, do any of the preference options still work, like the audio output settings, adding nas mounts, changing wifi settings, etc? Also, I’m not sure what is all included with in volumio’s raspbian, but it already seems pretty stripped down, was there much advantage moving it to pibang?

I played around with pibang also and just wanted to make my own music player; something simple with mpd and shairport. The web ui isn’t that important to me since I prefer using ncmpcpp or mpod/mpad. I unfortunately stopped because I couldn’t get one feature to work. I bought a pifacecad so i could get a display, some external buttons and IR capability. I couldn’t seem to get lirc working on pibang. Argh, so close! I can get lirc working on volumio though.

Hi Diet Shasta, check this thread for lirc on volumio

Sent from my Nexus 4 using Tapatalk

Thanks for the link Birka1987. Unfortunately, I’m not having a problem with lirc and volumio. It actually works as you’d expect like when installed on a vanilla raspbian installation.

The problem I’m having is getting lirc to work with the Pibang distribution. That’s what is sort of annoying about these heavily customized/minimized distributions. Sometimes it’s hard to tell what’s missing that makes a specific features not work. When I run the tests to see if it can see the remote when pressing random buttons, I get no response. I thought maybe the lirc_rpi kernel was not added, but it looks like it exists. I probably should post on pibanglinux to see if anyone has any ideas.

Cause is still a work in progress… Uploaded it for showing purposes …


i just visited Sourceforge and i was able to download 1.2 beta. Is it a new version still not announced?

Hi, I’m also not sure what’s included in Volumio’s Raspbian as michelangelo hasn’t informed us yet…ahem! :wink: I’d read a little bit about PiBang before discovering Volumio and as it was a purpose build lightweight distro, I thought it’d be good to try and get Volumio to play nicely with it.

You’re right about certain features not working though, I’d neglected to include the necessary file permission changes in my tutorial just before the step where you copy the system files from the git source. you need to do the following…

chmod 775 /var/www/_OS_SETTINGS/etc/rc.local chmod 755 /var/www/_OS_SETTINGS/etc/php5/mods-available/apc.ini chmod -R 777 /var/www/command/ chmod -R 777 /var/www/db/ chmod -R 777 /var/www/inc/
then copy the files again to / with

sudo cp -var /var/www/_OS_SETTINGS/etc /

reboot and you’re good to go. the command included in rc.local is integral to Volumio. upon boot, this script is executed and Volumio makes the necessary changes to update preferences etc. if this script is not permitted to run then nothing happens and the necessary preferences aren’t updated.

It’s also a good idea to remove the molly-guard package included with PiBang with

apt-get -y remove molly-guard

when you run sudo reboot or shutdown, molly-guard forces you to input the hostname of the server you want to reboot. I’m pretty sure this package will interfere with the ability to shutdown/reboot via Volumio UI. my blog post has been updated with these changes.

I don’t know anything about the lirc issues as I don’t have the hardware, but maybe these file permissions will do the trick? Let me know if it helps!

Thanks Ebsy for your response. I hate molly guard too. hah. After reading Michaelangelo’s other response on the tinkering post, I think i’ll probably go back to my Volumio sd and just give up on pibang. I’ve spent way too much time trying to troubleshoot this one lirc issue.

I love the mysterious :wink: back end stuff that Michaelangelo has built into volumio. I knew there was some magic there! The webui is a bonus, but never really felt that was what volumio was all about.

You’re welcome!

I’ll probably go back to Volumio OS myself, it’s just I’m more of a tinkerer than an audiophile these days.
But, I learned a lot about Linux in the process and if this little project somehow spurred michelangelo on to release the information that he did, then I would say it’s a job well done! :wink:

It is an hybrid version with mpd 18, upnp support and a new kernel. But it has a bug in the webui, so I didn’t announce it… I debugged it but still got no time to upload it again… You can use it, and you can update the WebUi with the latest on Github that fixes the problem.
I’ll upload it again when I have more time, with more fixes…
Let me know how it goes!

Yes Ebsy, you can be proud! First, I like your attitude: you weren’t linux savy, and you tinkered a while and now you’re enriched. I like it a lot, this is very similar to my story. Then I must admit, you gave me the rush to publish! You made me understand that Volumio’s community deserves more knowledge, not just a ready thing to play with.
I think you can improve what was done with Volumio so far, I strongly encourage you to be as constructive as you are! :wink:

One step further:

sudo mkdir -p /mnt/NAS sudo ln -s /mnt/NAS /var/lib/mpd/music/NAS
With this you get Volumio’s NAS library option working (after issuing those commands you can define access to network based music libraries via Volumio web GUI).

Perhaps it is very similar procedure for enabling “/mnt/USB/” (Volumio’s automounting of USB disk based libraries), but I have not tested it.

Anyhow - great writeup! …any chance of pointing us further on how to disable PiBang’s constant logging into “/var/log/” (and any other unnecessary SD card wearing OS features/apps).

First of all, great guide… I did receive an error when trying to clone the web-ui. I received CA certificate errors. Any thoughts?

hmm. Didn’t see that myself. Did a quick Google and apparently other people have that problem too. you have two options. one is to install a load of CA Certificates or simply temporarily ignore CA Certification with

env GIT_SSL_NO_VERIFY=true git clone /var/www

obviously, env GIT_SSL_NO_VERIFY=true being the key part.

Let us know if it worked! :slight_smile:

Hi Ebsy…
A big thank you for the guide.
With it’s help I’ve managed to get Volumio running on a BananaPi,A20 based sbc.The distro used is Bananian,a lightweight Debian build much like PiBang.

USB-Audio works well,USB,RAMPLAY,Webradio etc all work as expected.

The only hiccup seems to be the “System commands” in the System Menu…restart,poweroff,clearqueue etc… don’t work.
On clicking,I get back to the same Settings.php page without actual restart, poweroff etc happening.
Even the notifications like “reboot player initiated” , “shutdown player initiated” etc do not show up on clicking the appropriate button.

Could you please help me with this as I’m not too much of a PHP-NGinx-JS guy.
Where should I look?

Thanks again.