FusionDsp : the complete Dsp center for Volumio3!

Can you give more details please.
What is the FusionDsp version?
Volumio version?
How to reproduce the issue?
Do you use preset?

Good evening. Sorry, I was quick to ask a question. I have two ancient macmini, one of them had such a problem, I thought it was a re-phase settings file. moved it to the second player there no problem.Tried to reset to factory settings the problem remained. Reinstalled the system again and everything works.

Good. I think you had v1.0.21 that was not working properly (fixed issue now).
But if ok, enjoy!

FusionDsp v1.0.27 beta

  • Bump to camilladsp v1.0.2!
  • Cosmetic Camilladsp GUI uses Volumio colors.
  • Online help is can now be download and translated
  • Headphones list updated.

Warning : This is a beta, need to remove previous, reboot, install… Settings are lost
DOES NOT work with arm6l (RPI ZERO…)
Enjoy :wink:

1 Like

I’ve been trying to use FusionDSP to play a sweep file and have REW analyse the results. I’m not having much luck figuring it out. I can’t even figure out how to get REW to record the sweep. I hit start in REW and then start the sweep file in Volumio. Nothing happens!! Is there a guide out there that will help? I need REW for Dummies!!

First Steps with REW

Turn your Loudspeaker from Pc down, after starting Measure, press Play in Volumio, to start the Measurefile from Volumio Storage.
I think here is not the right Thread.
There is a Thread named „Fusion How to“

1 Like

This is just to provide some good feedback and congrats to the development team. Great work !! Using Volumio on an Rpi for years, I just updated to 3.378 on my Rpi-2B, installed and configured FusionDSP (1.0.25) with a couple of EQ build with REW, and this little thing works like a charm ! Very impressive. I feel like I was waiting for this one for ages, it changes everything. The HW configuration is quite simple, at purpose : home made streamer with Rpi-2B with a 5" display and Audiophonics ON/OFF system, feeding an SMSL AD-18 amplifier in USB, and a pair of TRIANGLE ANTAL EX.
Fantastic job ! Long life to the Volumio project.

1 Like

So pleased to read you :slightly_smiling_face:!
Did you used the import function in FusionDsp for Rew Eq?
Thanks for your feedback and enjoy music :musical_note:

1 Like

Hello there,
It’s my modest contribution :blush:
Actually, I just copied/paste the txt files generated by REW in /data/INTERNAL/FusionDsp/peq folder, as recommended. It’s a fairly easy process.
BTW yesterday I had system crashes when tweaking the FusionDSP settings while playing music (forgot to pause music before updating the settings).
I mainly stream music from a NAS and from Radio Paradise through the plugin.
Thank you for your participation in making quality music accessible to as many people as possible. :+1:

Oh… What is this crash? It shouldn’t happen! Even while playing!
Can you please provide log just after it happens?
Thanks a lot. This is very important to improve volumio and or FusionDsp.

Hi, here is a log : 52d5a2faa455b4bd0c3941dd05922eca . Hope I caught it at the right moment.
I tried another REW filter when I was listening to Radio Paradise, then tried to switch to some music on my NAS to give it a try. The GUI was working but the new music didn’t come up, Play/Pause ineffective. I tried a soft restart which didn’t cure the problem. I then tried to switch the system OFF from the GUI and it didn’t. Only a hard restart allowed me to recover full functionnality.
I have 4 active plugins : FusionDSP, Radio Paradise, Audiophonics ON/OFF and Touch Display.
Hope this will help.

Please send the html link for the log.

Oups, my bad, I’m learning…

FusionDsp v1.0.28 stable
– Not for armv6l device (RPI0) –

  • Bump to camilladsp v1.0.2!
  • Cosmetic: Camilladsp GUI uses Volumio colors + hidden output section
  • Online help is can now be download and translated
  • New clipping detection for convolution filter
  • Headphones list updated.

Enjoy :wink:


Can you please disable Loudness, reboot and try to reproduce the issue before sending log?
What value you set cause the issue? Very important to know it.

Hi, just upgraded to 1.0.28 of FusionDsp.

I use Airplay exclusively to listen to my music.

However it does not look like FusionDsp works with Airplay after numerous reboots and hearing the bootup tune there is no sound output.

you mean no sound?
was is working before update?
can you send log please?

you mean no sound?
No sound at all. I did manage to get it working once, but now there is no sound.

was is working before update?
Yes, but erratic requiring lots of reboots

can you send log please?

I have the same issue


Last update shouldn’t affect airplay as no change on the alsa pipeline. I’m testing for half an hour with an Iphone 7 with no problem.
Does other sources work as expected?