FusionDsp for Volumio3 stable (old beta thread)

Yes, of course.

From the plugin settings, you can download test tracks.(Sweep’s and PN tracks)

i tried to screenshot it, but it wont open the settings now it seems.(i just updated to 3.139 and 0.1.1 FusionDSP)


http://logs.volumio.org/volumiobuster/eKllhvO.html (Live Log got stuck on loading uiconfig for plugin, without further messages, when trying to navigate in there)

E: the plugin shows as enabled, but inactive in the plugin screen and there is no way to activate it, ill restart the PI if you dont need any further logs?

Very weird.
Is it a fresh install or an update?
I can’t see line about the plugin in your log.
Please reboot, try to reproduce the issue and right after send log.
But files provided are generated directly by REW. The may be not tagged. But you have to use the play button in the plugin to play them.
Did you installed from the store?
Delete the plugin and reinstall.
If not better, then restore Volumio to factory…

Btw, I see for the unnamed folder for tools files. I’ll see if something is possible :stuck_out_tongue_winking_eye:

Volumio was updated from the version which was before the current, for the plugin i think the update did jump couple of versions.

Restart did seem to cure things, now the plugin is active again.

i only install plugins from the store, and do not tweak anything with SSH.(i really need the “out of box” volumio experience for my app developement.)

In fact, max value for eq = Frequency/2 -1
Eq 5 is 22149Hz…
So CamillaDsp can’t compute it.
Values are checked in the plugin when you type them (1-20000Hz), but not with imported eq.
So, if you want to stay very close, change value in imported file to 22049 or set a value <20000Hz in UI.
In any case, you can’t hear the difference…

Do you mean with Qobuz?

2 Likes

I pushed a version 0.1.5 where frequency is limited at 22049Hz when you type in es. When imported from a file, a value superior to 22049 is converted to 22049… So now it should work with your files :wink:

1 Like

It can be cool to add a small switch button to the playing screen (the main screen) to quickly change the profile who is loaded in fusion dsp.

For exemple, i listen music sometime with headphones, sometime on speakers, for both i made 2 differents profiles, and i have to go each times in settings-plugin-load profile…Before listening music, and i can’t remember whish profile is already loaded !

3 Likes

I just came to the forum to ask for the same thing :smiley:

hi! yes this is something we are working on…But nothing to share yet :wink:
Custom preset and enable/disable effect would be enough?
Apart this point, can you give more details of your use, hw, sources and type of Eq please.
Thanks

2 Likes

Hi Balbuze,
Same as David_S, I use Speakers and Headphone, it’s the also the name of my Presets.
I use ParamEQ, Headphone settings are imported from AutoEQ, I use crossfeed and gain. Speakers have no setting for ParamEQ for now, no crossfeed, gain back to 0.
Use RPi 3 B+ with Hifiberry DAC+Pro, V3.111 (not RC1).

1 Like

Ok.
Why do you use gain? You need a different level L/R?

Hello,
In my Raspberry Pi setup (a very old raspberry), I get an alsa error when trying to play a file after enabling the FusionDsp plugin. I have Volumio 3.150 and a NuForce uDAC-2 USB DAC. With the FusionDsp disabled, playback works fine.

Here is the log: http://logs.volumio.org/volumiobuster/O5OsjXr.html

image

@balbuze can you advice him in this?

Can you test by setting ‘headphone’ as output in Volumio playback settings. Then, try to play a track. Let me know
Edit : something is wrong in the install. Can you remove the plugin and reinstall please?
What is the model for the RPI?

I use gain -6.6 on L/R because it’s what they say on the AutoEQ page. I’m doing what I’m told :slight_smile:
I don’t know why it says to use -6.6 db see here

It’s a Raspberry Pi Model B Plus, Hardware revision 0010. I did a factory reset and reinstalled the plugin before posting yesterday. I will retry with a fresh install this evening.

You don’t need to set an attenuation in the plugin. Everything is done automatically.
Left and right attenuation in the plugin is if you want to set a different level between left and right. It is added to the calculated value by the plugin.
In other words, don’t touch it :wink:

A file required is not properly linked in your installation. I don’t understand why because your hardware is detected as arm and thus supported.
Need more investigation.
But, I’m afraid your going to have a bad experience due to the lack of power… Even if I never tested Rpi2, I doubt it can handle convolution filter. But maybe 15 bands EQ is fine…
First step, make it install…

Sorry for my late reply. Indeed I was refering to the Qubuz poblem (only playing the first track of an album and then the UI being unresponsive).