FusionDsp for Volumio3 beta

Can you test by setting ‘headphone’ as output in Volumio playback settings. Then, try to play a track. Let me know
Edit : something is wrong in the install. Can you remove the plugin and reinstall please?
What is the model for the RPI?

I use gain -6.6 on L/R because it’s what they say on the AutoEQ page. I’m doing what I’m told :slight_smile:
I don’t know why it says to use -6.6 db see here

It’s a Raspberry Pi Model B Plus, Hardware revision 0010. I did a factory reset and reinstalled the plugin before posting yesterday. I will retry with a fresh install this evening.

You don’t need to set an attenuation in the plugin. Everything is done automatically.
Left and right attenuation in the plugin is if you want to set a different level between left and right. It is added to the calculated value by the plugin.
In other words, don’t touch it :wink:

A file required is not properly linked in your installation. I don’t understand why because your hardware is detected as arm and thus supported.
Need more investigation.
But, I’m afraid your going to have a bad experience due to the lack of power… Even if I never tested Rpi2, I doubt it can handle convolution filter. But maybe 15 bands EQ is fine…
First step, make it install…

Sorry for my late reply. Indeed I was refering to the Qubuz poblem (only playing the first track of an album and then the UI being unresponsive).

I can confirm that I get the same behavior with a clean “minimal” install (without the USB DAC or other plugins). Here you can find the log: http://logs.volumio.org/volumiobuster/tpKJWbL.html
One thing I noticed when installing the plugin was that the package is for armhf and the RPi 1 is detected as armv6l. I’m guessing this might be a problem, though I know nothing about arm architectures.

Thanks for the insight. It may not be worth the effort trying to support this device if it clearly cannot run all features of the plugin.

Ok, the problem is identified. It will be fixed ASAP in next version :stuck_out_tongue_winking_eye:. I’ll tell you when ok.

3 Likes

Great, thanks! :grinning:

Plugin looks great, but unfortunately I can’t hear the sound…
I use 3.150 version x86, only other plugin installed is System information 3.0.0 version…
Once installed, I just enabled the plugin, rebooted Volumio and used the Parametric EQ and set Peaking Hz, dB, Q as 102, -2.6, 2.4…applied, hit playback and no sound :frowning:
Tried also the 15 band EQ but w/o luck…once uninstalled and rebooted sound is back…

log file attached:
http://logs.volumio.org/volumiobuster/Qu2a6LD.html

I see no error…
No need to remove reboot, disabling is enough.
What is your sources?
Try to play a radio.

Thanks, sources are either internal SSD (its MSI Cubi mini PC) or USB flash drive attached…I have switched to web radio as advised but still silent.
Also, just disabling plugin will not help to bring sound back, I have to disable and reboot…

new log:

http://logs.volumio.org/volumiobuster/y2zfQAM.html

Install for armv6l devices (Rpi0, RPI2 B) should be now ok with version 0.1.9 (and other fixes)
But you have to wait until it is validated to be able to install it…

There is something strange going on with the install script. Without reflashing, I removed the FusionDsp plugin and then tried to install 0.1.9 beta. This was the result:

However, I was able to install the plugin manually and it works. The RPi 1 B+ seems to be able to handle at least the 15-band EQ with rougly 50% overall cpu load. I will continue experimenting with convolution filters later.

Update: I can confirm the RPi 1 B+ is not capable of running convolution filters. I will have to update my hardware.

thanks for your feedback. Same limitation with RPI 0.

1 Like

After installing 0.1.9 (and earlier versions with no issues) , I can start playback however I get no sound. I can disable the plugin and restart - the sound returns. I am using x86 and topping E30 via USB. Any thoughts.

Hello. Can you please share log?
https://volumio.github.io/docs/User_Manual/Sending_logs_for_troubleshooting.html

Will not allow me to upload log file.

http://logs.volumio.org/volumiobuster/30yWxMf.html

I tested ad reproduce the problem…
This very difficult to understand what is wrong…
BTW I update the plugin in test mode with some minor adjustement To v0.01.10