Frustrated New Primo Owner Cannot mount NAS (Netgear ReadyNAS 314)


I just replaced a dying SBT with a Primo. I have it working but cannot load my music library from my NAS.

"NAS drive shares (CIFS & NFS) are easily mounted and scanned by Volumio for audio content.+ says the FAQ. Not for me :). I am not super technical, but this is nuts. The scan did not work, so:

In Volumio settings, I have entered the static IP address of the NAS, every permutation for the path, set file share type to NFS.

On the NAS, I have enabled NFS and allowed access from the IP address of the Volumio device as instructed by the FAQ.

7 hours into the setup and I have given up for now.

What I find so strange is that I can browse from Volumio’s browser interface to my music files no sweat. I can also use the Squeezelite plug-in but it’s a disaster.

Any suggestions from a kind soul?

The latest error messages I receive state that “access is denied by the server while mounting.”

Oh, and the touchscreen I purchased for it will not work. Took me an hour to get it to display ANYTHING. Another to get it to actually display the GUI rather than a Linux command prompt for v volumio login. But one thing at a time…

Cheers from Basel Switerland.

Sorry for your troubles, but we can help you get them sorted.
First, I would suggest using SMB rather than NFS.
If its super easy to get it going .

If you need more troubleshooting, with the Primo you have access to our priority support at support at volumio dot org :wink: We will gladly help you from there, even by phone if that helps

Thanks. After much searching and trial and error, I have mounted my NAS library.

For those who might experience the same issues I had, I dropped trying the NFS route, as you suggested. I just could not get it to work. Also, SMB is now only listed on your GUI as CIFS.

Here are the settings to use under “Settings/Sources” to get my Netgear ReadyNAS to work with Volumio.

  1. Start by clicking on the “advanced” tab
  2. Enter the IP address of the NAS
  3. To enter the “path” you cannot just copy and paste from a Macintosh path. It puts an extraneous forward slash at the beginning of the text string which screws everything up. Also, whereas my Mac listed the path starting with “/Volumes” I had to instead enter the actual name I had given the share from within the ReadyNAS admin page when I set up the NAS. The easiest way to get the correct path was to go back to the ReadyNAS admin page, select the “shares” tab, then drill down to the right folder and pick up the path from the top of the screen (NB: ReadyNAS uses BACKslashes “”, which I switched to forward “/” when manually typing the path into the Volumio settings. It also starts the path with the name of the NAS itself, which you need to disregard).
  4. Select “cifs” for the file share type
  5. Enter the Ready NAS admin user ID and password.
  6. Under options, type “sec=ntlm”
  7. Save and pray :wink: