Fresh install not able to boot

I had the Asus Tinkerboard which I tried to install the latest version of volumio but after flashing complete, I put in the micro SD card and it not loading up. The red, orange and yellow will keep blinking. Not able to get connected at all. I am using wired connection for this. I had format and re flash a few times with same result. Even try different micro SD card with same result. Anyone can help ? I am using windows to do flashing with Win32diskimage

This sounds like the problem I had with my Tinkerboard S:

Try the TinkerOS image to make sure that your board works properly, TinkerOS is quite lightweight and it mostly boots with a keyboard and display plugged in. Volumio is more demanding.

Eventually I was able to get things to work for Volumio by unplugging everything except the display (not even a keyboard during bootup) - and give it maybe 5 minutes to come up. Once it comes up cleanly, try plugging the mouse and keyboard to see it it remains stable. Also check to make sure you are using a good USB cable - the Tinkerboard S seems to use a lot of power at bootup, and the skinnier USB cable I had never seems to succeed in booting, but a thicker cable seemed to work if everything else is unplugged. My USB power supply is supposed to be 2.4A, but maybe it lies.
I’ve ordered some upgraded USB cables that are rated for 2.4A from Amazon, they should arrive by Wed. I’ll post a followup if they seem to make bootup more reliable.