Force SRC on I2S output using airplay?

I am trying to get my Raspberry Pi to speak with a custom DAC/DSP chip I am using. This DAC requires a 48000kHz/24bit I2S stream. My primary way to get audio to the RPi is through airplay.

I have attempted to enable the sample-rate converter as a first step. I set it to resample everything to 44.1/24bit and I have used a scope to verify this is working for web radio and local content. I am now running into two problems:

  1. ) 48000/24bit is not an option for the SRC. I am hoping this is an easy change in software.
    2.) The sample-rate converter has no effect with AirPlay input. The I2S line stays at 44.1/16bit regardless of the SRC setting. Can I force this?