Flash BBB

Can I flash the internal memory of the Beaglebone Black instead of using the flash card?

Yes you can! I didn’t test this (planned to make an automatic procedure from the webui later), but it should work. With lots of benefits also…
Let me know!

First, thanks for all the hard work! I am very excited to try it out.
Sorry for my ignorant, how can I flash to replace the internal OS?

Let me check on that. I can come out with an easy script for you to launch…
I know that pressing that tiny button is a bit a pain on the ass… Just hold on a while and we sort this out…

Hope it’s not a problem to resurrect this post.

Did anyone manage to flash Volumio to the Beaglebone’s eMMC memory? Any tips about how to do so would be greatly appreciated.


I want to know too!!


Bump - any update on this?


I did this awhile ago. There are most likely better ways to go about this but it worked for me.

  1. setup a standard BBB debian image on an 8gig sd card expand the partition to full size (just so you have enough free space)
  2. boot the BBB and copy the unzipped Volumio BBB img file to your home directory, it should be around 1.8gig (I used WinSCP)
  3. login (I used Putty) to the BBB and issue this command
    sudo dd if=my_volumio_image.img of=/dev/mmcblk1 bs=1M

This will copy the unpacked image file into your eMMc memory.

remove you 8gig card and reboot

I then reformatted the 8gig card, copied a bunch of mp3’s to it and added as a another drive on the BBB

Good luck

dsfraser, good, but too hard. Should be easier.

Just SSH to your working under sdcard BBB (user - root, password - volumio) and enter this command:

sudo dd if=/dev/mmcblk0 of=/dev/mmcblk1 bs=1M (but I tried without bs and it works too)

Even if your sdcard is bigger than 2Gb, it works (in this case after dd command system will notice, that there was not enough place during copying, just ignore it)

Under which version(s) of Volumio did you test this?


On last. 1.55

I just did this on my BBB, works great! It took a long time. It was one of those things where I almost aborted because it felt like it shouldn’t take that long. But I left it alone, and went and did something else for a while, came back, and all was good. I didn’t time it, but I’m guessing it took upwards of 10 minutes to copy.

Just a hint for anyone else who does this.


I try to use the same command to work on the Volumio 2, but it doesn’t work this time. Anyone has any idea? Not sure I need to modify the uEnv.txt or install any pkg? Thanks.


I have the same problem. Unable to flash emmc with volumio. I tried several scripts but with no success.
Do you know how it is possible to transfert volumio on this flash unit ?
Thanks a lot

Has anybody successfully flashed Volumio 2 to the BBB’s built in eMMC? I’m currently running Volumio 2 on a Odroid 2, and volumio2 on the eMMC is super fast! Really great! But now, I’m getting ready to do a new system with BBB and twisted pear audio’s BBB isolator, cronus reclocker, and Buffalo III DAC.

Any info would be great!