first boot issues..

oke guys (and girls) i’m stuck here at the very beginning and hope you guys can help me a little over this first hurdle.

At first i’m not a complete nitwit… I know my way around linux (ubuntu) as i have been using it for about 3 years on my main machine, mainly via GUI but am not affraid to open a terminal either.

I recently receveid my raspberry pi, and had only one SD card. Installed raspbian on it via the noobs system. really didn’t use much with it as i wanted to install ubuntu mate on it, and not via the noobs system but via flashing the .img on it. As i tried the “dd” way via linux and things just seem to end up on my linux machine in some folders on a partition named data. I use this as a shared folder drive for both windows and linux for the time when i need t escape back to windows for what ever reason. anyway, it comes on the linux machine and not the SD card. so i’m doing something wrong there.

As i understand that it is easy to wreck you system when using dd wrong, which i was doing so i decide to escape to windows and installed it via the special sdcard flasher program “win32diskimager” which worked.

So today i received an other SD card from over the mail (8GB class 6) and wanted to install volumio via in the same way. Really didn’t realise at that time that volumio is a headless system from scratch so i connected all to my display, keyboard, mouse, wifi dongle (don’t have a dac for now but that will come later) . turned it on and saw that two of the raspberry pi led turned on (red and green(yellow?)) but it turned on, no blinking nothing.

realised that it was all headless, turned it off and realised that i would need to get to the network router from where i get my wireless signal, which is in the room next door (neighbour) . which i did (but don’t want to do to often as i don’t want to distrub them although they don’t seem to mind it as much.

anyway. I connected the raspy via a network cable to the router, and turned it on via usb via the router (one of those tv, phone, network, wifi boxes from the local tv… network) samething. and no rasppy on the network visible. tried to connect via the volumio local link but nothing.

remembered that at one point i owned a cross link utp cable. thought it was black and this white but one can make mistakes so i looked for another, which i found. (only other one) and this seemd more of a normal cable, also shorter, and all the clips were still on there so i tried that one.
again didn’t work. so 2 leds steady on the rasppi, no recognition of it actually booting what so ever. no network lights flashing on the rasppi either, not did the connected to the network light on the router light up.

so i really don’t know what to do. two installs, two network cables, multiple tries and nothing.

all i could think of is that:

  1. install isn’t good, allthough i did two attempts via the same way as i did before for ubuntu mate which worked
  2. SD card is F*&ked, but it formats, it installs and without error messages
  3. two UTP cables are both not oke, or one not oke and one a cross-linked.
  4. network port of the rasppi is F*&ked.

while writing this down i thought i ought to be able to differentiate from these…

So first thought about checking if the rasppi was still functional by booting in the ubuntu mate which i know to work and boot.
Which it did (thank god) then i thought to connect the utp cables to my own pc, and the leds turned on… didn’t make a working network connection. Would take more time than it would get me help full info, i believe.

Than i thought to check the new SD card if it was actually functioning. So i copied the noobs install on it and put it in the rasppi. No problems there.
Now i was thinking about getting a new download for volumio (download this time instead of torrent) and reinstall it the same way i did before with volumio and ubuntu mate… unfortunately this is some what slower… but it got done eventually.

and it actually booted, also network port had some flashing lights and the router to found that there was an network connection but upon
the volumio.local/ it didn’t find a network
nmap did find two IP adresses after switched all network connections from phone and tablet of, but i’m not sure if that would be my laptop itself and the router or the laptop and the rasppi and i don’t know how to find out. I’m not to knowledged on networking i must admitt (most of you probably allready figured this :wink: )

Anyway, i tried both network cables, same issue with both. Double checked after switching to windows once again (hate that) as that didn’t find anything in its network browser part.

so… All this… sorry for such a long text but i didn’t want to leave anything out.

2 questions… well 3 actually ofcourse.

  1. is it possible to do all this while connecting to a laptop instead of the router?
  2. how do i find out if the network cable is crossed or not? besides the obvious visiual reference, but this isn’t clear on this particular cable.
  3. the most importent one. any idea how to solve this at all, i tried anything i knew to check but definately open to ideas

In case you had the network leds flashing, there should have been a connection.
Let’s check that first, oogle for “Advanced IP scanner”, download and install it on your windows laptop.
Connect your raspi to your network and boot, then wait for a minute or so.
Start Advanced IP scanner and check if it finds a device called volumio.
If so, open the browser and type the ip address from the volumio device and you should be in.
Pls. let us know…

oke thanks!

i will definately do that… But since i have been at it nearly al day and since i have a exam coming up next friday i kinda stopped for today.
so it will probablybe for after friday before i can let you know anything about this.

In the mean time i did connect a old sitecom mime-xl (wl-153) to the original router from the supplier so i have some controle over my own network. als i ordered a utp cable (china so it will take a while) that way i can make a little hole through the wall and have the router on my side of the wall.
Not that that is really necessairy for this but still it will be handy in the long run.

Strange enough i couldn’t really see any ip’s connected to te router even though the raspi and laptop were conected both.
But that is when i got fedd up and decided to quit, and afterwards read your message.

Anyway i did indeed find out that the network cables are functional.

This will continue…

ps: also i feel like a re flash of the SD card at this time could also be rather functional as i have booted it quite a few times without access but never been able to turn it off and pulling out the cable just like that isn’t good for any sytem.


couldn’t wait… really i have hardly any self controle what so ever… but oke. it didn’t take that long.

answer: nope.

I found 2 alive. being the router itself and my laptop but not the volumio one. both the router as the raspi’s light for connection were on so it must be the software that has crashed or something… so as i said before i think it really will not be such bad idea to reflash it again and boot as a first time.

besides that i must say that there is a password on the router… but that is just for wireless and for entering the admin page… i believe that that is of no issue just thought to mention it anyway.

Grtz Matthieu.

much! seriously that network scanner thingy is super!
but now i got stuck in a different way. I will want to go wireless… I d understand that this is an entirely differen topic and is something that is should read into first but… for now this is what i did and what i will do…

reflashed the SD again. and now booted it wth the usb wifi module in the raspberry pi… Tried the add ssid and password. which work… for so far that then it responded with: No Wireless Interface Present

so there must be a recognition problem somehow…
the wifi dongle thing works perfectly with ubuntu mate. so nothing wrong with that there.
what kind…: well it is a comfast cf wu810n… which has a realtek rtl 8188eus chipset.

now i allready oogled and found this link:

which is about the same problem but with a rtl 8188eu chip not the eus, but it feels to me that there should be a similar solution for that one too, maybe even the same but i will need to read into that one. If anyone allready heas read into that and found or dind’t find a solution please feel free to let me know, Other wise i will resolve this one after the exam(s) honoustly this time.

I got it to work so far so wurst case is to find a different dongle.

greatz Matt

ps: anyone tried connecting logitech z10 speakers to a raspberry ? don’t worry i will oogle it or try it myself.

Hi I have also just acquired a second raspberry pi 2 for the sole purpose of using volumio. I also tried installing volumio 1.55 twice on sd cards. As you have said the pi does not boot at all just has red power light and green disk access light on. There are no lights on the Ethernet connection. I haven’t got the patience for any more trouble shooting as it is obvious the 1.55 image is defective. I have tried OSMC which works first time reliably so I will stick with that!