Files from mounts not showing (permissions?)


I have a problem with my volumio install. It may sound similar to other problems I had seen so far, but it is slightly different and even a lot of googling around could not solve it. Well, first things first, my hardware and software:

  • RaspberryPi 2
  • Volumio version: 2.031
  • NAS with Openmediavault 3.something
  • Ancient netgear modem/wlan ap/switch as a switch in between
    Both NAS and Raspi have static IPs.

Now on to my problem:
I tried mounting the NAS via the web UI which then shows me a success, but if I scan for media, no files are found. The shared folder contains about 3000 songs, mostly mp3 and some m4a (no idea if the 10000 song bug is still there). If I log into the ssh shell and go to /mnt/NAS/nas1 (yeah, I know, creative name :stuck_out_tongue:) I can browse and see all folders and files, but I only have access to it as root.

I tried plugging in a USB drive with ~100 songs on it (mp3 and m4a, again) and it is instantly mounted and the songs are recognised and playable. Also, I can browse that mount in the SSH shell as user volumio, without the need to go root.

I tried setting the NAS rw for all users on the shared folder for smb/cifs, still the same. I did not figure out how to connect via nfs at all, so far. The webgui simply shows that it can not be mounted, without tellingme any reasons. I would prefer cifs anyway, seen that all other clients in the house are communicating with the NAS using smb.

Btw, I even tried reflashing the Raspi once with a new install, that did not change anything either. I start running out of ideas. It must be some sort of permission problem, seen that I can browse all shared music as root, but the webgui does not seem to be allowed to browse it. Do you think my problem is on the Pi or in the configuration of the NAS? No other client in the house is making any trouble with smb.


Try to manually launch a rescan after mounting it.
Or, add the ability to read for guests in your NAS…

I just allowed guests for the music folder in openmediavault, set up the share again in Volumio (after a clean install), pressed the rescan button and hit refresh - still no songs popping up, even after a couple of minutes.

/mnt/NAS/nas is still not accessible as user volumio, only as root.

[code]volumio@volumio:/mnt/NAS$ cd nas
-bash: cd: nas: Permission denied

root@volumio:/mnt/NAS# cd nas