feedback on the Hifi Berry DAC

Hi users,

I have bought a Hifi Berry DAC from (I have no relation with them, I’m just a user). Previsouly, I have tried everything to get sound working with a USB DAC, but it never went up to my expectations. Pops, noise, bad quality, etc.

I have learned electronics, and thought I knew how to solder stuff, but due to my aging eyes, I had to use an optic magnifier to solder the Berry connectors. If you are hesitant, you might want to ask someone young with good eyes to do the job, as the spacing is small, and an unwanted pin short-circuit would be quick to do.

Anyway, got mine mounted, and whow, that stuff never pops or noise, just music.

I had to edit /etc/modules like this:

snd_soc_bcm2708 snd_soc_bcm2708_i2s bcm2708_dmaengine snd_soc_pcm5102a snd_soc_hifiberry_dac snd_soc_rpi_dac
and after a reboot, it worked fine. The hardware mixer doesn’t work (always at 100%) so I switched to software mixer.
Even airplay works without any issue. That was never the case before. Note I’m using cabled ethernet connection, as it is 1m away from my switch.

I can’t judge the sound quality, because I’m not a high-end fan with expensive gear, but my small Edirol studio monitors are doing good with Radio Paradise, and that alone make me happy and code faster :wink:

Thanks all for this wonderful hardware and software !


Ditto, installed my DAC over the weekend. It was easy to install and now it’s blissful to hear.

DItto :smiley:


Received my HiFiBerry yesterday. Got it up and running in less than an hour.
Board is marked 1.4 and also the RCA jacks are coloured red and white which is nice.

Enabled I2S in Volumio (1.1beta) then edited /etc/modules and rebooted and it worked straight away.

Had my first listen to some 24/96 FLACs that I got free from the Linn site over Christmas.

My initial impressions are that it sounds very nice indeed! Thanks to Michelangelo and Crazy Audio!

Hi, I’m thinking about purchasing a raspberry pi along with a hifiberry Dac. I wonder what cases you all use. Standard raspberry pi cases seem to be too small?

Hi, I had this problem and came across someone who mentioned using lego. I Raided my sons brick stash and found it was perfect. The only problem was the base plate needs to be 13x9 and lego seem to mainly do even sizes therefore a double base made up of smaller bits reinforcing the other worked a treat. I used doors and flaps for the i/o’s and a see through cockpit part to view the led indicators.

Hilarious! Thank you for taking these photos. I assume plugging in and out is not difficult?

:smiley: no problem connecting anything. Once a layer of bricks goes around the edge the pcb’s fit snugly therefore it doesn’t slide around either! I also raised the Pi by placing flat bricks on the base at strategic positions, that way the solder under the PCB does not rub on the base.

I’ve got some clear bricks on order so I will have revision 2 soon!

I love the Lego case!

looking good mate :slight_smile: congratulations
I am waiting patiently to receive mine.

First attempt at a clear Lego case with an LED base. Its a bit tall as I don’t have enough clear flat pieces so had to use full height instead as well as the base being quite tall to house the battery powered LED’s

I got it to fit inside a Pibow Timber but it was a bit tricky. I had to cut some of the timber layers to make room for the DAC. I also removed the RCA video connector from the Pi to make room for the RCA audio chassis connectors which I bought separately on Ebay.

The DAC is great, I’m not an expert on audio quality but the improvement is really noticeable, the audio quality is fantastic! Also, I have not had a single audible glitch or pop since setting it up a couple of weeks ago. I love it and highly recommend it. I’ve been using it solely with Volumio 1.2 Beta.

I’d like to say a big thanks to Volumio and Hifiberry, I’m really pleased with this setup!

Thanks for your feedback. So it can be done although there ain’t no easy way ie prefabricated cases…

…and another pictures of Lego case (this time its portable rpi with hifiberry and amp) :wink:.



Ok , I have received my Hifiberry , soldered the header and removed the composite video connector and have hardwired in some braided phono cables . Powered up and set for I2S , mounted the NAS so far so good . Only problem is when I SSH in to add the code , I get command not found . Can anyone assist me (step by step) with how to enter the commands ?



If You use Volumio 1.2 beta, I don’t think you need to SSH and do any manual setup other than enabling I2S in the settings on the web interface, and restarting. I might be wrong, though, I don’t remember what I did!

Otherwise, copied from here, the steps:

# password: volumio. Change IP-ADDRESS to the IP of your Pi
ssh root@IP-ADDRESS

Then ssh again…

ssh root@IP-ADDRESS
# Edit /etc/modules using nano or vi....
nano /etc/modules
# make the contents match this...
# save and exit nano (it shows the commands at the bottom I think)

That should sort it.

Tried that but there appears to another issue . Whenever I activate the I2S dac in system settings , I am unable to play any music . The timer dial on the left hand side of the playback screen does not increment , have tried webradio and also files from my NAS . This Pi worked previously when running Raspyfi , Volumio and Rune without the I2S dac in place . I have tried with and without the patches via SSH . Each time to get the Pi to start playing a track etc I have to erase the SD card and start again and each time when I select I2S the same thing happens . I first used a file I downloaded about a month ago beta 1.1 and also just reloaded the latest image from the download section on the website (probably the same) . Issue remains the same . Very frustrating… Any ideas what I’m doing wrong ?



Are you confident that the soldering is good? It may be that one or more pins is not making a connection.

If it was me, I would do the following:

  1. Install the 1.2 beta, and try that … erry%20PI/ don’t forget to enable i2s and reboot (again!)
  2. Check out the HiFiberry website, they have a small test script you can run that runs some software diagnostics, downloads an audio file and plays it (a test tone)
  3. If still no joy, check the soldering is good on the pins on the Pi. Your software config might be fine

The diagnostics script can be found here along with some more tips … -software/

Good luck!

The holes are through plated and pads fairly large so it would be very difficult to mess this up apart from bridging between the header pads . The beta1.2 release you point me to states ‘this folder has no files’ so I cannot download .

I’ve wasted too much time already , I need music in the workshop so will be using the old USB dac . Maybe will retry the Hifiberry once there is a stable release available without all the mucking around . Thanks for your assistance