Failure to open ALSA

Volumio has been working great until I upgraded yesterday, now I am getting the “Failed to open “Alsa” [Alsa]; Failed to open ALSA device “hw:1,0”: No such file or directory.” message.

Searching this forum I found the solution is to “Please disable i2s dac, reboot, enable i2s dac again”

BUT when I go to settings/PlaybackOptions, where I think the i2s used to show up, there’s nothing there, just an empty background.

I have rebooted from the menu, shutdown from the menu and power-cycled the RPi, but still no joy.
I’ve tried to turn on TEST mode but in “volumio.local/dev/” none of the buttons appear to work for me.

Any suggestions or do I need to start again with a clean SD card?
Thanks, Bob

Would you share some system logs please?

Preferable from a fresh reboot

1 Like

Sure thing, but as soon as I started that I saw there was an update 2.907 (even though I updated 2 days ago)
I did the update and it works now!

Thanks for your help, feel free to delete this thread if you want to avoid causing confusion…