Failed to open "alsa"

Allo 5VDC

Thx Steve!
Is it the following one?
I’m using this, but still have this problem!?


I bought an IKEA Koppla extension socket with two built-in USB ports. So far - three days - I have not had a repeat of the dreaded Failed to open “alsa” with my Allo Boss/Pi Zero W combination.

Previously I was using an official Raspberry Pi PSU.

I am sorry to report that the issue has just reared its ugly head again. The different power source did not solve the problem.

I also thought with another PSU the problem is solved. Bought one from MeanWell (5V/4.3A), but still I have the same problem :smiling_imp:

I only can run Volumio with Adafruit MAX98357 set as Output device. I cannot control volume and do not know whether or how this affects the sound quality, but overall it’s pretty annoying :imp:

Considering that I haven’t had this problem in the beginning I assume that it’s either caused by a slow degeneration on the hardware side or that it’s linked with newer versions of Volumio. In case of the latter also others with the same configuration (RB PI 3B with Allo Kali & Piano 2.1) should have similar problems.

REALLY ANNOYING! :imp: :smiling_imp:

I’m having the same issue with Failed to open “alsa” error message. My setup is RPi3 B+ with Hifiberry AMP2 configured as Hifiberry DAC Plus. All the hardware is brand new. The error message appears randomly, sometimes Volumio works fine.

What is interesting that I’ve started facing this error message when I switched from RPi B+ to the new RPi3 B+.

Now I’m able to hear only the welcome sound and that’s it. There’s no sound at all no matter which I2S DAC I set, the only solution is to write image into SD card again (back to factory settings does not help).


how about if you set Adafruit MAX98357 as Output device?

Well, my “alsa” issue disappear itself but thanks, will check with Adafruit if I have the same issue again.

finally, I could cure the mistake a little more permanently. What helped was to disassemble and reassemble the player. Hopefully this will hold now. All in all not necessarily a good testimonial in terms of reliability. :cry:

Same problem for me with Boss DAC. I tried to up voltage to 5,2V with no effects. Now I’m exactly at 5V and the problem persists. I use a DIY PSU. My 2 micro usb cables(1 for RPi and 1 for Boss DAC) are optimized. I tested all the cables with the RPi(which needs 3,5A with the touch screen) and it works with all the cables so I don’t think the problem comes from the cable. I don’t know where to look for to solve this bug. I can’t listen to music with my volumio system at the moment :imp: :imp: :imp:

Hi DipterePow,
have you tried to dissassemble the device and rebuild it completely?
I have tried a lot of things, nothing helped, but this finally cured it sustainably !
Regards Axel

Hi Axel,

can you explain the meaning of disassembling and rebuilding? I hope you mean flashing a new sd-card?
Gerne auch in Deutsch…


Nein, nein, hier wird English geschrieben, sollen ja auch andere mitgeniessen :slight_smile:

As an interesting fact:
I have the same problem since I’ve updated my volumio a few days ago. I thought it may be a bug, so I’ve installed moode audio on my Rpi 3b (Hifiberry DAC+). Guess? Same failure notice.
Maybe a hardware breakdown? Is there any possibility to check if the DAC HW is working correctly?

Thanks to all answers :sunglasses:

Check. It was worth the try… :mrgreen:

I had same Alsa problem since October. Running Pi Zero (original, non-wireless) with IQaudio Pi Dac Zero & official Raspberry Pi usb wifi adapter. I had updated Volumio to latest version a few weeks ago but the problem remained. I then found & reinstalled previous images from August 2019 & Jan 2018 neither of which made any difference. I tried removing & refitting the dac which made no difference.
Tonight I removed the dac & wireless adapter & connected a usb hub, reconnected same WiFi adapter. Booted Volumio using the Jan 2018 image. Using ‘playback options’ settings then removed i2s dac, connected an Audioquest Dragonfly black, selected this in settings, pressed play to play a web radio station, got the ‘playback started’ confirmation message but then no Alsa errors. May have restarted the Pi at some point. Then shutdown, removed dragonfly, reconnected Pi Dac Zero, adjusted settings, hit play, no Alsa errors.
Have now reconnected Pi+Dac to audio amp as before & it still plays ok without Alsa errors.
So for me solution is to unplug everything, change config from I2s dac to Usb dac then reverse the process back to exactly (in theory) how it was before. Good luck!

Did anyone suss this?
I have a feeling that mine is fine unless i unpklug it from the mains.

I always switch it off at the socket anyway, but whenever i do something a bit more major than that, I struggle to work out what the issue, then suddenly it works, then works seemingly forever until I pull the plug out again or something.

Unless that is a coincidence obviously.
It is so frustrating.