Failed to open ALSA device "hw:2,0"


I use a Raspberry Pi 3 Model B Plus Rev 1.3 with a HiFiBerry Amp2.

Failed top open “alsa” [alsa]; Failed to
open ALSA device “hw:2,0”: No such
file or directory.

No sound out of the speaker.
Any idea how to handle this error?

Kind regards

Do you use a touchscreen?

In my case starting from zero helped…

No, I do not use a touchscreen.

did you set your output? settings>> playback options >> output device

I2S DAC: “On”
DAC Model: “HifiBerry Amp2”

Sorry, my first answer was wrong.
I disabled the touchscreen, and now it works.
But now I can not use the touchscreen.

Any ideas?

What touchscreen do you have (brand and model) and how is it connected?

Did you disable the touch display plugin or did you disconnect the screen from the Pi physically?

Raspberry Pi 7-Inch Touch Screen Display
Connected via Pins and wideband cable.
I disconnected it from the pi physically.

If that means that you have also SDA and SCL connected (not only +5V and Ground): Remove the wires for SDA and SCL.

Sorry, what does SCA and SCL mean?

SDA is “Serial Data Line” and SCL is “Serial Clock Line” of the i2c bus which is used by the display and the DAC. SDA is physical pin 3 and SCL is physical pin 5 of the 40pin GPIO connector on the Pi.

The wiring shown in the pictures on this page in section “Step 1” is wrong for newer Pis. They are only required for old Model A/B boards where the DSI connector does not have I2C connections. With your Pi 3B Plus SDA and SCL signals are transmitted via the DSI ribbon cable so the yellow and the green wire would have to be removed.

Thanks a lot amazing! It works!

Multiple use of same GPIOs caused this.
That’s why I asked :smile:

I did the same failure…

Mark this thread as “solved”


@volumio Since this wiring issue has been reappearing multiple times IMHO the wiring instructions in the tutorial should be reworked as described here.