Fail to open ALSA device error on Volumio 2.703

Hey guys I encoutered a very strange situation after a recent update of Volumio from an old Volumio version released in 2019 to the latest v2.703.

As I choose to play something from Volumio’s Browse tab(for a folder, by “Clear and play”, “Play” or for a song by clicking on the title), there is a 50% chance that Volumio pops up the following message and won’t start playing:

Fail to open "alsa" [alsa]; Error opening ALSA device "hw:5,0"; snd_pcm_hw_params() failed: No such device or address

Right after that, if I change from the Browse tab to Queue tab, and click on any of the song titles, it starts playing smoothly.

I tried setting I2S DAC on and back to off, still the same. Flashing brand new Volumio v2.703 image and mount my NAS all over, still the same. Changing from the currently using RPi 3B to RPi 4B, still the same. However when I tried an old Volumio image v2.201, the problem is gone and everything went smooth.

My RPi 3 currently connects to a Denon PMA50 DAC/Amplifier via USB interface. And it’s been playing standard flac, hi-res flac and DSD for over 2 years very smoothly. Clearly the problem above is introduced by a recent Volumio modification. Is there anything I can do next, or is this a bug and I’ll have to wait for future Volumio update?

hey guys,

same problem here:

My System

Raspberry PI 4
newest Volumio Version
DAC = Marantz HD-DAC 1 via USB

Apr 26 14:22 : exception: Failed to open “alsa” [alsa]
Apr 26 14:22 : exception: nested: Error opening ALSA device “hw:5,0”
Apr 26 14:22 : exception: snd_pcm_hw_params() failed: No such device or address

I tested something.
The problem seems to be when switching different codecs.
Like from mp3 to FLAC 24bit / 96 to FLAC 24bit / 44 etc.

Do you have a solution to the problem?

Greetings Uwe