External usb stick not visible

Hi all,

I successfully installed Volumio on an SD card and I have an external USB Stick with some music that I want Volumio to add the Music folders in the Music Library. BUT Volumio is not seeing any USB stick (I tried with 4 different sticks/hdd).

The USB is correctly mounted on the raspberry (dmesg tells me that is correctly read) and in /var/lib/mpd/music/USBI can see thestorage` folder (name of my USB with the music):

volumio@volumio:~$ ls /var/lib/mpd/music/USB

I tried the same USB formatted in ext4 and FAT but with always the same result.

Every time I plugged the USB I went to Volumio and I clicked on both rescan and update library. Nothing there.

Is there any setting that I’m missing?

Cheers and thanks for any help


What do you see when you look at your ‘Music Library’ and select USB? Do you see ‘storage’ and can you see files?

1 Like

I don’t see any chance where to choose my USB:

I couldn’t find any setting that I have to activate in order to see external USB or HDD. I read that Volumio automatically recognizes them

Please navigate to “Music Library” in the left panel

this is the page of the “Music Library”. i don’t have any music on the SD card, just on the USB stick

seems that Music Library doesn’t show in the right order i would advice a re-install
but do this after your free myvolumio, i think you could lose the free trail.

I’m not interested (for now) to the free trial so do you really suggest to reinstall Volumio from scratch?

normal if you press on music library you see no items , did you scan for the usb already?
system / sources you can update or rescan after this it should show up.

if you mean on “Settings → Sources” I rescan and update the library yes.

i think there is something wrong in the system after reinstall it should be oke again
is this after a update to 2.882 or fresh install?
my version only shows icon’s so system or setting i could not read that one any more

fresh install of VERSION: 2.882

what pi do you use? p0 p1 p2 p3 p4 / gb?
what are your skills can you manual install plugins?
otherwise you could try a 3.xx version maybe that works better for you…

wait. I reinstall Volumio from scrath, always the same version an in the meanwhile I formatted completely (by erasing all the data) the external Hard Drive. Now it is seeing it!

I formatted the external HDD as FAT32 while the USB stick is ext4 (but I read it shouldn’t give troubles).

Tried also to reboot and the hdd is still here :slight_smile: seems solved but what could have happened? Does Volumio require some HDD or USB formats (like FAT32 or whatever?)

i think that something went wrong in the install normal it shows no items if it’s empty.
and it didn’t do that with yours. and if it shows now it went well if you want to use it on a pc
i would pick fat32 windows doesn’t support ext4

well, still weird. Thanks for the support and yes, i know that ext4 is not compatible with Windows, but I don’t have any Windows machine around :wink:

then you could use what you like, if you have any questions just ask we are here to help.

thanks again!

your welcome :slight_smile: