External USB HD / SSD

I am looking to identify external HD / SDDs that work well on RP4 / Volumio without any issues to recommend to friends.
Looking at this blog post, there are a number of USB enclosures / SSDs that cause issues with RP4 in general (and probably with Volumio).
I would like the USB disk to be able to use UASP and TRIM and to have a good performance, as my library is around 3TB in size
It seems enclosures using asm1153E work well if updated to the latest FW.
I would prefer an off the shelf solution like the Crucial X6 (asm235CM up to 2TB, Phison U17 in 4TB model), as my friends are not technically savvy.
I would appreciate any inputs on this.

It seems to me that the issue with USB disks more often than not is the detection process by Volumio and not the disk itself. See my findings here:

USB disk not detected - Help and Support / Help - Volumio

Are you able to tell any difference, from a lsusb perspective, of a working vs non working USB enclosure?
Can you tell what changes with the firmware update on this?

The behaviour seems quite erratic. I have just done some testing now and lsusb -t did not make any difference (both on USB3 and USB2 ports). I could not get the USB disks to be detected.

As suggested by @gkkpch I then used “udevadm monitor --env” to monitor behavior as I plugged in the two USB disks. Here are the results:

Crucial x6 after a factory reset of Volumio 2.882:

Crucial x6 USB after reset.txt (20.4 KB)

Crucial x6 after detection worked before:

Crucial x6 USB used before.txt (20.5 KB)

Seagate Spinner Disk after reset of Volumio 2.882:

Seagate USB after reset.txt (18.5 KB)

I hope this helps with diagnosis

The plot thickens.
The two USB disks still do not show up in Volumio. So I have tried some things and found the following:
See the following screenshots of my SSH session:

  1. lsusb -t shows the USB disk is detected but not mounted
  2. I created a mountpoint manually with sudo mkdir /mnt/USB/MyMusicDisk
  3. I mounted the USB disk using sudo mount /dev/sda1 /mnt /USB/MyMusicDisk
  4. lsusb -t now shows the disk mounted as /media/MyMusicDisk

Volumio is happily reading the music library on the disk

I read somewhere that USB disks in Volumio are mounted as internal disks by default. This seems to work rather unreliably, as USB disks are often not detected this way.

@volumio Would it be possible to adapt the detection routine for disks so that USB disks are reliably detected? The problem seems to exist also in Volumio 2.882, not only in Buster
Thanks a lot

After a few reboots of the RP4, the USB disk has changed its mountpoint to /media/4TB_SMR
4TB_SMR is the label of the USB Disk