expanding partitions

So I have Volumio running on rpi with a 32GB sd card. Which seems to be after adding a few mb of music to NAS!

pi@volumio:/$ df -h
Filesystem Size Used Avail Use% Mounted on
rootfs 1.5G 1.4G 0 100% /
/dev/root 1.5G 1.4G 0 100% /
devtmpfs 108M 0 108M 0% /dev
tmpfs 24M 692K 23M 3% /run
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 256M 0 256M 0% /run/shm
/dev/mmcblk0p1 75M 20M 55M 27% /boot
Ramdisk 256M 0 256M 0% /run/shm

OK so tried the rpi config. But got a message that the partition layout is not what it expects.

How do I expand rootfs? It IS rootfs that I am expanding?

Thanks in advance etc

After messing up the SD card installation trying to resize the partition I got inspired by someone on this forum setting up a new partition for their library rather than increasing the size of the existing one, but didn’t give instructions I could find …

So I have success following the “Adding a partition” instructions below…

elinux.org/RPi_Easy_SD_Card_Setu … mmand_line

Then I added the symbolic links to the mounted device… (below from udoo-quad-issues-t483.html?hilit=link#p1803)

cd /var/lib/mpd/music ln -s /mnt/**partition drive name***

NOTE “cd /var/lib/mpd/music/NAS” instead and then adding the symbolic link there might remove the need to mess with Samba.

Then rebuilding the Database and my new partition appears!

I then added the mounted partition to the Samba server, by editing the Samba config file with …

sudo nano /etc/samba/smb.conf
… I basically copied one of the existing entries but changed the folder location and shared name.

Restart Samba with

sudo /etc/init.d/samba restart

Now I have a local Volumio library on my 32Gig SD Card available via the network.


You will need to do this

“Don’t forget to also edit this in the main configuration, otherwise it is lost when rebooting the Pi (at least in my case).
Same trick, but then in the file: /var/www/_OS_SETTINGS/etc/samba/smb.conf”

For the Samba config AND the fstab_raspberry file (in _OS_SETTINGS) or your changes will get over written on reboot and you will believe you have gone mad!!

Hi there,

I had the same issue when I tried to expand using the “raspi-config” script. The following instructions did it for me.


Cool it worked for you. I did something to make the card unbootable and had to start again. Think I renamed partition 3 to 2 while resizing.