es9023 i2s setting

I 've got a audiophonics diy i2s dac 9023 with raspberry pi rev B.
It can play music with no problem. As it seems that this dac do not integrate an hardware mixer, I set Volumio in sotfware mod.
As I read that software mixer will alter the sound quality, I was wondering if I have to resample to the max of the dac can ie 24/196 ? When I set that, I have to set also fastest sinc interpolator or it cliks, drop off slowdown the music etc. Even with fast sinc it cliks when changing music . So what is at your advice the best setting to be used ? Is there a trick ? Another stupid question : the driver iss hifiberry. Do I have to use a other one ?
the dac is … -8396.html
Thanks a lot for your great job !

I did various tests with my dac and resampling. So what I saw, is that when I play music without resampling the cpu load of the raspeberry is less than 1%.
With 24/96khz mpd uses about 45%
With 24/192khz mpd eats 92% !
And that with fast sinc interpolator.
A strange thing, when playing via airplay, with the same setting, cpu load falls to less than 1% (I thaught that all was resample)
So, it’s seems that the raspberry pi overload Is in cause in case of clicks and drop-off.
I carry on with test :slight_smile: