Error opening Volumio

Volumio Version: 2.806
Hardware: RPI 2B + HiFi Berry Digi Plus Pro,
DAC: Homemade based on CS4398

Some guidance please.
This Media Player is built in to my PreAmp. I wanted to upgrade my RPI but the built in 5V PSU wouldn’t be able to power a RPI 3 let alone a 4. As a result I have changed from the internal PSU to an external Allo Shanty
It powers both the RPI with it 3Amp output and the PreAmp 5V logic with its 1Amp output.
Since this change I sometimes get the following error when I try to open Radio Paradise.

I think it could be due to the sequence components power up, but its a guess as I don’t understand the error!
I also switched on the Volumio Error log and it gave the following:
VolumioError.txt (4.8 KB)


Your posted log is incomplete …

Would you share some system logs please?

Preferable from a fresh reboot, with minimal steps to reproduce the problem :slight_smile:

Thanks for the reply, sorry I thought I had as I have not had this problem before.
Set the ‘Send Error’ log and this what was recorded, hope I have done this correctly.

Tried a re-power of the Analogue circuits in the PreAmp, i.e. the RPI and logic circuits stayed powered up. Same error. Tried a RPI re-boot from Volumio. Same error.
What does the ALSA error mean, is it a ‘failed to make a hardware connection’ sort of error?

Looks like your DAC isn’t being recognised. How do you initiate it?

**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
  Subdevices: 4/4
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 IEC958/HDMI [bcm2835 IEC958/HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: ALSA [bcm2835 ALSA], device 2: bcm2835 IEC958/HDMI1 [bcm2835 IEC958/HDMI1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Headphones [bcm2835 Headphones], device 0: bcm2835 Headphones [bcm2835 Headphones]
  Subdevices: 3/3
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2

Thanks Ash,
I think I have tracked down the reason, and it is embarrassing !
Somehow Volumio had been set to have a ‘Hardware Mixer’, and it hasn’t. Must have been me but I don’t recall doing it !!!
Funny thing is that it did work sometimes.